Skip to content

← Actionable
High, CVSS 7.5amended

Authlib: JWS/JWT accepts unknown crit headers (RFC violation → possible authz bypass)

CVE-2025-59420GHSA-9ggr-2464-2j32

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (authlib 1.6.4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI authlib

    Affected
    < 1.6.4
    Fixed in
    1.6.4

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
EPSS
  • CVE-2025-59420: 0.26% estimated exploitation activity in the next 30 days; percentile 18.06 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Authlib’s JWS verification accepts tokens that declare unknown critical header parameters (crit), violating RFC 7515 “must‑understand” semantics. An attacker can craft a signed token with a critical header (for example, bork or cnf) that strict verifiers reject but Authlib accepts. In mixed‑language fleets, this enables split‑brain verification and can lead to policy bypass, replay, or privilege escalation. Affected Component and Versions - Library: Authlib (JWS verification) - API: authlib.jose.JsonWebSignature.deserializecompact(...) - Version tested: 1.6.3 - Configuration: Default; no allowlist or special handling for crit Details RFC 7515 (JWS) §4.1.11 defines crit as a “must‑understand” list: recipients MUST understand and enforce every header parameter listed in crit, otherwise they MUST reject the token. Security‑sensitive semantics such as token binding (e.g., cnf from RFC 7800) are often conveyed via crit. Observed behavior with Authlib 1.6.3: - When a compact JWS…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-9ggr-2464-2j32

  2. Revision 1 · created ·

    Published from osv record GHSA-9ggr-2464-2j32

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-59420

Advisory: Authlib: JWS/JWT accepts unknown crit headers (RFC violation → possible authz bypass)
IDs: CVE-2025-59420, GHSA-9ggr-2464-2j32
Record: https://patchnext.com/advisories/cve-2025-59420 (revision 2, source checked 26 Oct 2026, 13:35 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: authlib 1.6.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI authlib: affected < 1.6.4; fixed in 1.6.4

## Suggested inspection (read-only)
- `python -m pip show authlib`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on authlib.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-9ggr-2464-2j32 (OSV record GHSA-9ggr-2464-2j32 lists affected ranges: PyPI authlib >=0 <1.6.4 (fixed))
- Verified: https://github.com/advisories/GHSA-9ggr-2464-2j32 (GitHub-reviewed advisory GHSA-9ggr-2464-2j32 lists affected ranges: PyPI authlib >=0 <1.6.4)

Commands are suggestions: review each one before running it.

Loading voting…