Lobe Chat Desktop vulnerable to Remote Code Execution via XSS in Chat Messages
CVE-2025-59417GHSA-m79r-r765-5f9j
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@lobehub/chat 1.129.4), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm @lobehub/chat
- Affected
- <= 1.129.3
- Fixed in
- 1.129.4
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-m79r-r765-5f9j lists affected ranges: npm @lobehub/chat >=0 <1.129.4 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-m79r-r765-5f9j lists affected ranges: npm @lobehub/chat >=0 <=1.129.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 6.8 · CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:P · score source
- EPSS
- CVE-2025-59417: 0.43% estimated exploitation activity in the next 30 days; percentile 37.57 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary We identified a cross-site scripting (XSS) vulnerability when handling chat message in lobe-chat that can be escalated to remote code execution on the user’s machine. Any party capable of injecting content into chat messages, such as hosting a malicious page for prompt injection, operating a compromised MCP server, or leveraging tool integrations, can exploit this vulnerability. Vulnerability Details XSS via SVG Rendering In lobe-chat, when the response from the server is like <lobeArtifact identifier="ai-new-interpretation" ... , it will be rendered with the lobeArtifact node, instead of the plain text. https://github.com/lobehub/lobe-chat/blob/0a1dcf943ea294e35acbe57d07f7974efede8e2e/src/features/Conversation/components/MarkdownElements/LobeArtifact/rehypePlugin.ts#L50-L68 https://github.com/lobehub/lobe-chat/blob/0a1dcf943ea294e35acbe57d07f7974efede8e2e/src/features/Conversation/components/MarkdownElements/LobeArtifact/index.ts#L7-L11…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-m79r-r765-5f9j
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-m79r-r765-5f9j
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-59417 Advisory: Lobe Chat Desktop vulnerable to Remote Code Execution via XSS in Chat Messages IDs: CVE-2025-59417, GHSA-m79r-r765-5f9j Record: https://patchnext.com/advisories/cve-2025-59417 (revision 3, source checked 26 Oct 2026, 12:38 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @lobehub/chat 1.129.4. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @lobehub/chat: affected <= 1.129.3; fixed in 1.129.4 ## Suggested inspection (read-only) - `npm ls @lobehub/chat --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @lobehub/chat. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-m79r-r765-5f9j (OSV record GHSA-m79r-r765-5f9j lists affected ranges: npm @lobehub/chat >=0 <1.129.4 (fixed)) - Verified: https://github.com/advisories/GHSA-m79r-r765-5f9j (GitHub-reviewed advisory GHSA-m79r-r765-5f9j lists affected ranges: npm @lobehub/chat >=0 <=1.129.3) Commands are suggestions: review each one before running it.
Loading voting…