DragonFly's tiny file download uses hard coded HTTP protocol
CVE-2025-59410GHSA-mcvp-rpgg-9273
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/dragonflyoss/dragonfly 2.1.0; d7y.io/dragonfly/v2 2.1.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go github.com/dragonflyoss/dragonfly
- Affected
- < 2.1.0
- Fixed in
- 2.1.0
- Affected
- < 2.1.0
- Fixed in
- 2.1.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-mcvp-rpgg-9273 lists affected ranges: Go github.com/dragonflyoss/dragonfly >=0 =0 <2.1.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 5.5 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N/E:P · score source
- EPSS
- CVE-2025-59410: 0.14% estimated exploitation activity in the next 30 days; percentile 3.32 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact The code in the scheduler for downloading a tiny file is hard coded to use the HTTP protocol, rather than HTTPS. This means that an attacker could perform a Man-in-the-Middle attack, changing the network request so that a different piece of data gets downloaded. Due to the use of weak integrity checks (TOB-DF2-15), this modification of the data may go unnoticed. A network-level attacker who cannot join a peer-to-peer network performs a Man-in-the-Middle attack on peers. The adversary can do this because peers (partially) communicate over plaintext HTTP protocol. The attack chains this vulnerability with the one described in TOB-DF2-15 to replace correct files with malicious ones. Unconscious peers use the malicious files. Patches - Dragonfy v2.1.0 and above. Workarounds There are no effective workarounds, beyond upgrading. References A third party security audit was performed by Trail of Bits, you can see the full report. If you have any questions or comments about this…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-mcvp-rpgg-9273
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-59410 Advisory: DragonFly's tiny file download uses hard coded HTTP protocol IDs: CVE-2025-59410, GHSA-mcvp-rpgg-9273 Record: https://patchnext.com/advisories/cve-2025-59410 (revision 1, source checked 26 Oct 2026, 15:10 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/dragonflyoss/dragonfly 2.1.0; d7y.io/dragonfly/v2 2.1.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/dragonflyoss/dragonfly: affected < 2.1.0; fixed in 2.1.0 - Go d7y.io/dragonfly/v2: affected < 2.1.0; fixed in 2.1.0 ## Suggested inspection (read-only) - Go github.com/dragonflyoss/dragonfly: check the installed version with your package manager. - Go d7y.io/dragonfly/v2: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/dragonflyoss/dragonfly, d7y.io/dragonfly/v2. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-mcvp-rpgg-9273 (GitHub-reviewed advisory GHSA-mcvp-rpgg-9273 lists affected ranges: Go github.com/dragonflyoss/dragonfly >=0 =0 <2.1.0) Commands are suggestions: review each one before running it.
Loading voting…