Skip to content

← Actionable
Medium, CVSS 5.0

Open Web Analytics Server is vulnerable to SQL Injection

CVE-2025-59397GHSA-6w8r-xgqq-qg6g

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (open-web-analytics/open-web-analytics 1.8.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.0 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:N/A:N
EPSS
  • CVE-2025-59397: 0.42% estimated exploitation activity in the next 30 days; percentile 36.59 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Open Web Analytics (OWA) before 1.8.1 allows SQL injection.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-6w8r-xgqq-qg6g

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-59397

Advisory: Open Web Analytics Server is vulnerable to SQL Injection
IDs: CVE-2025-59397, GHSA-6w8r-xgqq-qg6g
Record: https://patchnext.com/advisories/cve-2025-59397 (revision 1, source checked 26 Oct 2026, 14:34 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.0)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: open-web-analytics/open-web-analytics 1.8.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist open-web-analytics/open-web-analytics: affected < 1.8.1; fixed in 1.8.1

## Suggested inspection (read-only)
- Packagist open-web-analytics/open-web-analytics: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on open-web-analytics/open-web-analytics.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-6w8r-xgqq-qg6g (GitHub-reviewed advisory GHSA-6w8r-xgqq-qg6g lists affected ranges: Packagist open-web-analytics/open-web-analytics >=0 <1.8.1)

Commands are suggestions: review each one before running it.

Loading voting…