Skip to content

← Actionable
Medium, CVSS 6.9amended

express-xss-sanitizer has an unbounded recursion depth

CVE-2025-59364GHSA-hvq2-wf92-j4f3

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (express-xss-sanitizer 2.0.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
6.9 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2025-59364: 0.45% estimated exploitation activity in the next 30 days; percentile 39.08 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Security Advisory: express-xss-sanitizer Overview A vulnerability was discovered in express-xss-sanitizer that allowed unbounded recursion depth during sanitization of nested objects. Affected Versions - All versions prior to 2.0.1 Patched Versions - 2.0.1 and later Description The sanitize function in lib/sanitize.js performed recursive sanitization without depth limiting, making it vulnerable to stack overflow attacks via specially crafted deeply nested JSON objects. Impact An attacker could cause denial-of-service by sending a request with deeply nested structures, potentially crashing the Node.js process. Solution Upgrade to version 2.0.1 or later:

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-hvq2-wf92-j4f3

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-hvq2-wf92-j4f3

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-59364

Advisory: express-xss-sanitizer has an unbounded recursion depth
IDs: CVE-2025-59364, GHSA-hvq2-wf92-j4f3
Record: https://patchnext.com/advisories/cve-2025-59364 (revision 3, source checked 26 Oct 2026, 12:38 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: express-xss-sanitizer 2.0.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm express-xss-sanitizer: affected < 2.0.1; fixed in 2.0.1

## Suggested inspection (read-only)
- `npm ls express-xss-sanitizer --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on express-xss-sanitizer.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-hvq2-wf92-j4f3 (OSV record GHSA-hvq2-wf92-j4f3 lists affected ranges: npm express-xss-sanitizer >=0 <2.0.1 (fixed))
- Verified: https://github.com/advisories/GHSA-hvq2-wf92-j4f3 (GitHub-reviewed advisory GHSA-hvq2-wf92-j4f3 lists affected ranges: npm express-xss-sanitizer >=0 <2.0.1)

Commands are suggestions: review each one before running it.

Loading voting…