DragonFly vulnerable to panics due to nil pointer dereference when using variables created alongside an error
CVE-2025-59351GHSA-4mhv-8rh3-4ghw
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/dragonflyoss/dragonfly 2.1.0; d7y.io/dragonfly/v2 2.1.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go github.com/dragonflyoss/dragonfly
- Affected
- < 2.1.0
- Fixed in
- 2.1.0
- Affected
- < 2.1.0
- Fixed in
- 2.1.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-4mhv-8rh3-4ghw lists affected ranges: Go github.com/dragonflyoss/dragonfly >=0 =0 <2.1.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 5.5 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N/E:P · score source
- EPSS
- CVE-2025-59351: 0.31% estimated exploitation activity in the next 30 days; percentile 24.43 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact We found two instances in the DragonFly codebase where the first return value of a function is dereferenced even when the function returns an error (figures 9.1 and 9.2). This can result in a nil dereference, and cause code to panic. The codebase may contain additional instances of the bug. Eve is a malicious actor operating a peer machine. She sends a dfdaemonv1.DownRequest request to her peer Alice. Alice’s machine receives the request, resolves a nil variable in the server.Download method, and panics. Patches - Dragonfy v2.1.0 and above. Workarounds There are no effective workarounds, beyond upgrading. References A third party security audit was performed by Trail of Bits, you can see the full report. If you have any questions or comments about this advisory, please email us at dragonfly-maintainers@googlegroups.com.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-4mhv-8rh3-4ghw
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-59351 Advisory: DragonFly vulnerable to panics due to nil pointer dereference when using variables created alongside an error IDs: CVE-2025-59351, GHSA-4mhv-8rh3-4ghw Record: https://patchnext.com/advisories/cve-2025-59351 (revision 1, source checked 26 Oct 2026, 15:10 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/dragonflyoss/dragonfly 2.1.0; d7y.io/dragonfly/v2 2.1.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/dragonflyoss/dragonfly: affected < 2.1.0; fixed in 2.1.0 - Go d7y.io/dragonfly/v2: affected < 2.1.0; fixed in 2.1.0 ## Suggested inspection (read-only) - Go github.com/dragonflyoss/dragonfly: check the installed version with your package manager. - Go d7y.io/dragonfly/v2: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/dragonflyoss/dragonfly, d7y.io/dragonfly/v2. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-4mhv-8rh3-4ghw (GitHub-reviewed advisory GHSA-4mhv-8rh3-4ghw lists affected ranges: Go github.com/dragonflyoss/dragonfly >=0 =0 <2.1.0) Commands are suggestions: review each one before running it.
Loading voting…