Dragonfly vulnerable to server-side request forgery
CVE-2025-59346GHSA-g2rq-jv54-wcpr
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/dragonflyoss/dragonfly 2.1.0; d7y.io/dragonfly/v2 2.1.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go github.com/dragonflyoss/dragonfly
- Affected
- < 2.1.0
- Fixed in
- 2.1.0
- Affected
- < 2.1.0
- Fixed in
- 2.1.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-g2rq-jv54-wcpr lists affected ranges: Go github.com/dragonflyoss/dragonfly >=0 =0 <2.1.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 7.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N/E:P · score source
- EPSS
- CVE-2025-59346: 0.25% estimated exploitation activity in the next 30 days; percentile 16.14 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact There are multiple server-side request forgery (SSRF) vulnerabilities in the DragonFly2 system. The vulnerabilities enable users to force DragonFly2’s components to make requests to internal services, which otherwise are not accessible to the users. One SSRF attack vector is exposed by the Manager’s API. The API allows users to create jobs. When creating a Preheat type of a job, users provide a URL that the Manager connects to (see figures 2.1–2.3). The URL is weakly validated, and so users can trick the Manager into sending HTTP requests to services that are in the Manager’s local network. A second attack vector is in peer-to-peer communication. A peer can ask another peer to make a request to an arbitrary URL by triggering the pieceManager.DownloadSource method (figure 2.4), which calls the httpSourceClient.GetMetadata method, which performs the request. Another attack vector is due to the fact that HTTP clients used by the DragonFly2’s components do not disable support for…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-g2rq-jv54-wcpr
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-59346 Advisory: Dragonfly vulnerable to server-side request forgery IDs: CVE-2025-59346, GHSA-g2rq-jv54-wcpr Record: https://patchnext.com/advisories/cve-2025-59346 (revision 1, source checked 26 Oct 2026, 15:10 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/dragonflyoss/dragonfly 2.1.0; d7y.io/dragonfly/v2 2.1.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/dragonflyoss/dragonfly: affected < 2.1.0; fixed in 2.1.0 - Go d7y.io/dragonfly/v2: affected < 2.1.0; fixed in 2.1.0 ## Suggested inspection (read-only) - Go github.com/dragonflyoss/dragonfly: check the installed version with your package manager. - Go d7y.io/dragonfly/v2: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/dragonflyoss/dragonfly, d7y.io/dragonfly/v2. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-g2rq-jv54-wcpr (GitHub-reviewed advisory GHSA-g2rq-jv54-wcpr lists affected ranges: Go github.com/dragonflyoss/dragonfly >=0 =0 <2.1.0) Commands are suggestions: review each one before running it.
Loading voting…