Dragonfly doesn't have authentication enabled for some Manager’s endpoints
CVE-2025-59345GHSA-89vc-vf32-ch59
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/dragonflyoss/dragonfly 2.1.0; d7y.io/dragonfly/v2 2.1.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go github.com/dragonflyoss/dragonfly
- Affected
- < 2.1.0
- Fixed in
- 2.1.0
- Affected
- < 2.1.0
- Fixed in
- 2.1.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-89vc-vf32-ch59 lists affected ranges: Go github.com/dragonflyoss/dragonfly >=0 =0 <2.1.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 7.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N/E:P · score source
- EPSS
- CVE-2025-59345: 0.38% estimated exploitation activity in the next 30 days; percentile 32.49 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact The /api/v1/jobs and /preheats endpoints in Manager web UI are accessible without authentication. Any user with network access to the Manager can create, delete, and modify jobs, and create preheat jobs. An unauthenticated adversary with network access to a Manager web UI uses /api/v1/jobs endpoint to create hundreds of useless jobs. The Manager is in a denial-of-service state, and stops accepting requests from valid administrators. Patches - Dragonfy v2.1.0 and above. Workarounds There are no effective workarounds, beyond upgrading. References A third party security audit was performed by Trail of Bits, you can see the full report. If you have any questions or comments about this advisory, please email us at dragonfly-maintainers@googlegroups.com.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-89vc-vf32-ch59
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-59345 Advisory: Dragonfly doesn't have authentication enabled for some Manager’s endpoints IDs: CVE-2025-59345, GHSA-89vc-vf32-ch59 Record: https://patchnext.com/advisories/cve-2025-59345 (revision 1, source checked 26 Oct 2026, 15:10 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/dragonflyoss/dragonfly 2.1.0; d7y.io/dragonfly/v2 2.1.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/dragonflyoss/dragonfly: affected < 2.1.0; fixed in 2.1.0 - Go d7y.io/dragonfly/v2: affected < 2.1.0; fixed in 2.1.0 ## Suggested inspection (read-only) - Go github.com/dragonflyoss/dragonfly: check the installed version with your package manager. - Go d7y.io/dragonfly/v2: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/dragonflyoss/dragonfly, d7y.io/dragonfly/v2. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-89vc-vf32-ch59 (GitHub-reviewed advisory GHSA-89vc-vf32-ch59 lists affected ranges: Go github.com/dragonflyoss/dragonfly >=0 =0 <2.1.0) Commands are suggestions: review each one before running it.
Loading voting…