Apache Fory Deserialization of Untrusted Data vulnerability
CVE-2025-59328GHSA-5hmf-8wx5-4qq3
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.fory:fory-core 0.12.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.apache.fory:fory-core
- Affected
- < 0.12.2
- Fixed in
- 0.12.2
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-5hmf-8wx5-4qq3 lists affected ranges: Maven org.apache.fory:fory-core >=0 <0.12.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2025-59328: 0.69% estimated exploitation activity in the next 30 days; percentile 52.66 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
A vulnerability in Apache Fory allows a remote attacker to cause a Denial of Service (DoS). The issue stems from the insecure deserialization of untrusted data. An attacker can supply a large, specially crafted data payload that, when processed, consumes an excessive amount of CPU resources during the deserialization process. This leads to CPU exhaustion, rendering the application or system using the Apache Fory library unresponsive and unavailable to legitimate users. Users of Apache Fory are strongly advised to upgrade to version 0.12.2 or later to mitigate this vulnerability. Developers of libraries and applications that depend on Apache Fory should update their dependency requirements to Apache Fory 0.12.2 or later and release new versions of their software.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-5hmf-8wx5-4qq3
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-59328 Advisory: Apache Fory Deserialization of Untrusted Data vulnerability IDs: CVE-2025-59328, GHSA-5hmf-8wx5-4qq3 Record: https://patchnext.com/advisories/cve-2025-59328 (revision 1, source checked 26 Oct 2026, 16:40 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.apache.fory:fory-core 0.12.2. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.apache.fory:fory-core: affected < 0.12.2; fixed in 0.12.2 ## Suggested inspection (read-only) - Maven org.apache.fory:fory-core: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.apache.fory:fory-core. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-5hmf-8wx5-4qq3 (GitHub-reviewed advisory GHSA-5hmf-8wx5-4qq3 lists affected ranges: Maven org.apache.fory:fory-core >=0 <0.12.2) Commands are suggestions: review each one before running it.
Loading voting…