Skip to content

← Actionable
Low, CVSS 2.1

vet MCP Server SSE Transport DNS Rebinding Vulnerability

CVE-2025-59163GHSA-6q9c-m9fr-865m

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/safedep/vet 1.12.5), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
2.1 · CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:A/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2025-59163: 0.41% estimated exploitation activity in the next 30 days; percentile 35.03 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

SafeDep vet is vulnerable to a DNS rebinding attack due to lack of HTTP Host and Origin header validation. To exploit this vulnerability following conditions must be met: 1. A vet scan is executed and reports are saved as sqlite3 database 2. A vet MCP server is running on default port with SSE transport that has access to the report database 3. The attacker lures the victim to attacker controlled website 4. Attacker leverages DNS rebinding to access vet SSE server on 127.0.0.1 through the website 5. Attacker uses MCP tools to read information from report database Impact Data from vet scan sqlite3 database may be exposed to remote attackers when vet is used as an MCP server in SSE mode with default ports through the sqlite3 query MCP tool. Patches v1.12.5 is released that patches the issue with Host and Origin header allow list and validation Workarounds Use stdio (default) transport for SSE server

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-6q9c-m9fr-865m

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-59163

Advisory: vet MCP Server SSE Transport DNS Rebinding Vulnerability
IDs: CVE-2025-59163, GHSA-6q9c-m9fr-865m
Record: https://patchnext.com/advisories/cve-2025-59163 (revision 1, source checked 26 Oct 2026, 15:13 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 2.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/safedep/vet 1.12.5. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/safedep/vet: affected < 1.12.5; fixed in 1.12.5

## Suggested inspection (read-only)
- Go github.com/safedep/vet: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/safedep/vet.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-6q9c-m9fr-865m (GitHub-reviewed advisory GHSA-6q9c-m9fr-865m lists affected ranges: Go github.com/safedep/vet >=0 <1.12.5)

Commands are suggestions: review each one before running it.

Loading voting…