matrix-js-sdk has insufficient validation when considering a room to be upgraded by another
CVE-2025-59160GHSA-mp7c-m3rh-r56v
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (matrix-js-sdk 38.2.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm matrix-js-sdk
- Affected
- < 38.2.0
- Fixed in
- 38.2.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-mp7c-m3rh-r56v lists affected ranges: npm matrix-js-sdk >=0 <38.2.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-mp7c-m3rh-r56v lists affected ranges: npm matrix-js-sdk >=0 <38.2.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 6.9 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2025-59160: 0.24% estimated exploitation activity in the next 30 days; percentile 15.60 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact matrix-js-sdk before 38.2.0 has insufficient validation of room predecessor links in MatrixClient::getJoinedRooms, allowing a remote attacker to attempt to replace a tombstoned room with an unrelated attacker-supplied room. Patches The issue has been patched and users should upgrade to 38.2.0. Workarounds Avoid using MatrixClient::getJoinedRooms in favour of getRooms() and filtering upgraded rooms separately.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-mp7c-m3rh-r56v
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-mp7c-m3rh-r56v
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-59160 Advisory: matrix-js-sdk has insufficient validation when considering a room to be upgraded by another IDs: CVE-2025-59160, GHSA-mp7c-m3rh-r56v Record: https://patchnext.com/advisories/cve-2025-59160 (revision 3, source checked 26 Oct 2026, 12:38 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: matrix-js-sdk 38.2.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm matrix-js-sdk: affected < 38.2.0; fixed in 38.2.0 ## Suggested inspection (read-only) - `npm ls matrix-js-sdk --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on matrix-js-sdk. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-mp7c-m3rh-r56v (OSV record GHSA-mp7c-m3rh-r56v lists affected ranges: npm matrix-js-sdk >=0 <38.2.0 (fixed)) - Verified: https://github.com/advisories/GHSA-mp7c-m3rh-r56v (GitHub-reviewed advisory GHSA-mp7c-m3rh-r56v lists affected ranges: npm matrix-js-sdk >=0 <38.2.0) Commands are suggestions: review each one before running it.
Loading voting…