Skip to content

← Actionable
Critical, CVSS 9.6amended

SillyTavern Web Interface Vulnerable DNS Rebinding

CVE-2025-59159GHSA-7cxj-w27x-x78q

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (sillytavern 1.13.4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.6 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H
EPSS
  • CVE-2025-59159: 0.25% estimated exploitation activity in the next 30 days; percentile 16.48 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The web UI for SillyTavern is susceptible to DNS rebinding, allowing attackers to perform actions like install malicious extensions, read chats, inject arbitrary HTML for phishing, etc. Details DNS rebinding is a method to bypass the CORS policies by tricking the browser into resolving something like 127.0.0.1 for a site's DNS address. This allows anybody to get remote access to anyone's SillyTavern instance without it being exposed, just by visiting a website. PoC 1. Host the PoC HTML file on a /rebind.html endpoint (or any other endpoint) on a web server on port 8000 2. Go to https://lock.cmpxchg8b.com/rebinder.html and input your IP address (A) to rebind to 127.0.0.1 (B) 3. Replace the URL in the HTML with the returned URL on the site 4. Go to http://[URL]:8000/rebind.html in firefox or on any mobile browser if you're using termux 5. Check the developer tools console. It should return all of the data Here is the PoC code: Impact Attackers can read user chats, inject HTML…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-7cxj-w27x-x78q

  2. Revision 1 · created ·

    Published from osv record GHSA-7cxj-w27x-x78q

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-59159

Advisory: SillyTavern Web Interface Vulnerable DNS Rebinding
IDs: CVE-2025-59159, GHSA-7cxj-w27x-x78q
Record: https://patchnext.com/advisories/cve-2025-59159 (revision 2, source checked 26 Oct 2026, 12:38 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.6)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: sillytavern 1.13.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm sillytavern: affected < 1.13.4; fixed in 1.13.4

## Suggested inspection (read-only)
- `npm ls sillytavern --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on sillytavern.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-7cxj-w27x-x78q (OSV record GHSA-7cxj-w27x-x78q lists affected ranges: npm sillytavern >=0 <1.13.4 (fixed))
- Verified: https://github.com/advisories/GHSA-7cxj-w27x-x78q (GitHub-reviewed advisory GHSA-7cxj-w27x-x78q lists affected ranges: npm sillytavern >=0 <1.13.4)

Commands are suggestions: review each one before running it.

Loading voting…