Skip to content

← Actionable
High, CVSS 7.5amended

Litestar X-Forwarded-For Header Spoofing Vulnerability Enables Rate Limit Evasion

CVE-2025-59152GHSA-hm36-ffrh-c77c

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (litestar 2.18.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI litestar

    Affected
    >= 2.17.0, <= 2.17.0
    Fixed in
    2.18.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2025-59152: 0.48% estimated exploitation activity in the next 30 days; percentile 41.81 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

While testing Litestar's RateLimitMiddleware, I discovered that rate limits can be completely bypassed by manipulating the X-Forwarded-For header. This renders IP-based rate limiting ineffective against determined attackers. The Problem Litestar's RateLimitMiddleware uses cachekeyfromrequest() to generate cache keys for rate limiting. When an X-Forwarded-For header is present, the middleware trusts it unconditionally and uses its value as part of the client identifier. Since clients can set arbitrary X-Forwarded-For values, each different spoofed IP creates a separate rate limit bucket. An attacker can rotate through different header values to avoid hitting any single bucket's limit. Looking at the relevant code in litestar/middleware/ratelimit.py around line 127, there's no validation of proxy headers or configuration for trusted proxies. Reproduction Steps Here's a minimal test case Testing the bypass Security Impact This vulnerability has several concerning implications: Brute…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-hm36-ffrh-c77c

  2. Revision 1 · created ·

    Published from osv record GHSA-hm36-ffrh-c77c

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-59152

Advisory: Litestar X-Forwarded-For Header Spoofing Vulnerability Enables Rate Limit Evasion
IDs: CVE-2025-59152, GHSA-hm36-ffrh-c77c
Record: https://patchnext.com/advisories/cve-2025-59152 (revision 2, source checked 26 Oct 2026, 13:35 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: litestar 2.18.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI litestar: affected >= 2.17.0, <= 2.17.0; fixed in 2.18.0

## Suggested inspection (read-only)
- `python -m pip show litestar`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on litestar.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-hm36-ffrh-c77c (OSV record GHSA-hm36-ffrh-c77c lists affected ranges: PyPI litestar >=2.17.0 <2.18.0 (fixed))
- Verified: https://github.com/advisories/GHSA-hm36-ffrh-c77c (GitHub-reviewed advisory GHSA-hm36-ffrh-c77c lists affected ranges: PyPI litestar >=2.17.0 <=2.17.0)

Commands are suggestions: review each one before running it.

Loading voting…