Skip to content

← Actionable
High, CVSS 8.8amended

backslash@0.2.1 contains malware after npm account takeover

CVE-2025-59140GHSA-53mq-f4w3-f7qv

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (backslash 0.2.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm backslash

    Affected
    >= 0.2.1, < 0.2.2
    Fixed in
    0.2.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.8 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:H/VA:N/SC:N/SI:N/SA:N/E:A/U:Red · score source
EPSS
  • CVE-2025-59140: 0.41% estimated exploitation activity in the next 30 days; percentile 34.88 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact On 8 September 2025, the npm publishing account for `backslash` was taken over after a phishing attack. Version `0.2.1` was published, functionally identical to the previous patch version, but with a malware payload added attempting to redirect cryptocurrency transactions to the attacker's own addresses from within browser environments. Local environments, server environments, command line applications, etc. are not affected. If the package was used in a browser context (e.g. a direct ` ` inclusion, or via a bundling tool such as Babel, Rollup, Vite, Next.js, etc.) there is a chance the malware still exists and such bundles will need to be rebuilt. The malware seemingly only targets cryptocurrency transactions and wallets such as MetaMask. See references below for more information on the payload.

Patches npm removed the offending package from the registry over the course of the day on 8 September, preventing further downloads from npm proper. On 13 September, the…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  2. Revision 1 · created ·

    Published from osv record GHSA-53mq-f4w3-f7qv

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-59140

Advisory: backslash@0.2.1 contains malware after npm account takeover
IDs: CVE-2025-59140, GHSA-53mq-f4w3-f7qv
Record: https://patchnext.com/advisories/cve-2025-59140 (revision 2, source checked 24 Oct 2026, 22:22 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: backslash 0.2.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm backslash: affected >= 0.2.1, < 0.2.2; fixed in 0.2.2

## Suggested inspection (read-only)
- `npm ls backslash --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on backslash.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-53mq-f4w3-f7qv (OSV record GHSA-53mq-f4w3-f7qv lists affected ranges: npm backslash >=0.2.1 <0.2.2 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…