Angular SSR: Global Platform Injector Race Condition Leads to Cross-Request Data Leakage
CVE-2025-59052GHSA-68x2-mx4q-78m7
What to do
Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm @angular/ssr
- Affected
- >= 17.0.0-next.0, < 18.2.21>= 19.0.0-next.0, < 19.2.16>= 20.0.0-next.0, < 20.3.0>= 21.0.0-next.0, < 21.0.0-next.3
- Fixed in
- 21.0.0-next.3, 19.2.16, 18.2.21, 20.3.0
npm @nguniversal/common
- Affected
- >= 16.0.0-next.0, <= 16.2.0
- Fixed in
- no fixed version recorded
npm @angular/platform-server
- Affected
- >= 16.0.0-next.0, < 18.2.14>= 20.0.0-next.0, < 20.3.0>= 19.0.0-next.0, < 19.2.15>= 21.0.0-next.0, < 21.0.0-next.3
- Fixed in
- 21.0.0-next.3, 19.2.15, 18.2.14, 20.3.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-68x2-mx4q-78m7 lists affected ranges: npm @angular/platform-server >=16.0.0-next.0 =20.0.0-next.0 =19.0.0-next.0 =21.0.0-next.0 =17.0.0-next.0 =19.0.0-next.0 =20.0.0-next.0 =21.0.0-next.0 =16.0.0-next.0 <=16.2.0
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-68x2-mx4q-78m7 lists affected ranges: npm @angular/platform-server >=16.0.0-next.0 =20.0.0-next.0 =19.0.0-next.0 =21.0.0-next.0 =17.0.0-next.0 =19.0.0-next.0 =20.0.0-next.0 =21.0.0-next.0 =16.0.0-next.0 <=16.2.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 7.1 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:H/VI:L/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2025-59052: 0.36% estimated exploitation activity in the next 30 days; percentile 29.31 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Angular uses a DI container (the "platform injector") to hold request-specific state during server-side rendering. For historical reasons, the container was stored as a JavaScript module-scoped global variable. When multiple requests are processed concurrently, they could inadvertently share or overwrite the global injector state. In practical terms, this can lead to one request responding with data meant for a completely different request, leaking data or tokens included on the rendered page or in response headers. As long as an attacker had network access to send any traffic that received a rendered response, they may have been able to send a large number of requests and then inspect the responses for information leaks. The following APIs were vulnerable and required SSR-only breaking changes: bootstrapApplication: This function previously implicitly retrieved the last platform injector that was created. It now requires an explicit BootstrapContext in a server environment.…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-68x2-mx4q-78m7
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-68x2-mx4q-78m7
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-59052 Advisory: Angular SSR: Global Platform Injector Race Condition Leads to Cross-Request Data Leakage IDs: CVE-2025-59052, GHSA-68x2-mx4q-78m7 Record: https://patchnext.com/advisories/cve-2025-59052 (revision 3, source checked 26 Oct 2026, 12:37 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Partial vendor fix; fixed versions by package: @angular/ssr 21.0.0-next.3, 20.3.0, 19.2.16, 18.2.21; @angular/platform-server 21.0.0-next.3, 20.3.0, 19.2.15, 18.2.14. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @angular/ssr: affected >= 17.0.0-next.0, < 18.2.21; >= 19.0.0-next.0, < 19.2.16; >= 20.0.0-next.0, < 20.3.0; >= 21.0.0-next.0, < 21.0.0-next.3; fixed in 21.0.0-next.3, 19.2.16, 18.2.21, 20.3.0 - npm @nguniversal/common: affected >= 16.0.0-next.0, <= 16.2.0 - npm @angular/platform-server: affected >= 16.0.0-next.0, < 18.2.14; >= 20.0.0-next.0, < 20.3.0; >= 19.0.0-next.0, < 19.2.15; >= 21.0.0-next.0, < 21.0.0-next.3; fixed in 21.0.0-next.3, 19.2.15, 18.2.14, 20.3.0 ## Suggested inspection (read-only) - `npm ls @angular/ssr --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. - `npm ls @nguniversal/common --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. - `npm ls @angular/platform-server --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @angular/ssr, @nguniversal/common, @angular/platform-server. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-68x2-mx4q-78m7 (OSV record GHSA-68x2-mx4q-78m7 lists affected ranges: npm @angular/platform-server >=16.0.0-next.0 =20.0.0-next.0 =19.0.0-next.0 =21.0.0-next.0 =17.0.0-next.0 =19.0.0-next.0 =20.0.0-next.0 =21.0.0-next.0 =16.0.0-next.0 <=16.2.0) - Verified: https://github.com/advisories/GHSA-68x2-mx4q-78m7 (GitHub-reviewed advisory GHSA-68x2-mx4q-78m7 lists affected ranges: npm @angular/platform-server >=16.0.0-next.0 =20.0.0-next.0 =19.0.0-next.0 =21.0.0-next.0 =17.0.0-next.0 =19.0.0-next.0 =20.0.0-next.0 =21.0.0-next.0 =16.0.0-next.0 <=16.2.0) Commands are suggestions: review each one before running it.
Loading voting…