OpenBao has potential Denial of Service vulnerability when processing malicious unauthenticated JSON requests
CVE-2025-59043GHSA-g46h-2rq9-gw5m
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/openbao/openbao 2.4.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- <= 2.4.0
- Fixed in
- 2.4.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-g46h-2rq9-gw5m lists affected ranges: Go github.com/openbao/openbao >=0 <=2.4.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2025-59043: 0.69% estimated exploitation activity in the next 30 days; percentile 52.75 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary JSON objects after decoding might use more memory than their serialized version. It is possible to tune a JSON to maximize the factor between serialized memory usage and deserialized memory usage (similar to a zip bomb). While reproducing the issue, we could reach a factor of about 35. This can be used to circumvent the [maxrequestsize (https://openbao.org/docs/configuration/listener/tcp/) configuration parameter, which is meant to protect against Denial of Service attacks, and also makes Denial of Service attacks easier in general, as the attacker needs much less resources. Details The request body is parsed into a map[string]interface{} https://github.com/openbao/openbao/blob/788536bd3e10818a7b4fb00aac6affc23388e5a9/http/logical.go#L50 very early in the request handling chain (before authentication), which means an attacker can send a specifically crafted JSON object and cause an OOM crash. Additionally, for simpler requests with large numbers of strings, the audit…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-g46h-2rq9-gw5m
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-59043 Advisory: OpenBao has potential Denial of Service vulnerability when processing malicious unauthenticated JSON requests IDs: CVE-2025-59043, GHSA-g46h-2rq9-gw5m Record: https://patchnext.com/advisories/cve-2025-59043 (revision 1, source checked 26 Oct 2026, 15:13 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/openbao/openbao 2.4.1. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/openbao/openbao: affected <= 2.4.0; fixed in 2.4.1 ## Suggested inspection (read-only) - Go github.com/openbao/openbao: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/openbao/openbao. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-g46h-2rq9-gw5m (GitHub-reviewed advisory GHSA-g46h-2rq9-gw5m lists affected ranges: Go github.com/openbao/openbao >=0 <=2.4.0) Commands are suggestions: review each one before running it.
Loading voting…