Skip to content

← Actionable
High, CVSS 8.5amended

Claude Code vulnerable to arbitrary code execution caused by maliciously configured git email

CVE-2025-59041GHSA-j4h9-wv2m-wrf7

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@anthropic-ai/claude-code 1.0.105), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.5 · CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2025-59041: 0.55% estimated exploitation activity in the next 30 days; percentile 45.76 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

At startup, Claude Code constructed a shell command that interpolated the value of git config user.email from the current workspace. If an attacker controlled the repository’s Git config (e.g., via a malicious .git/config) and set user.email to a crafted payload, the unescaped interpolation could trigger arbitrary command execution before the user accepted the workspace-trust dialog. The issue affects versions prior to 1.0.105. The fix in 1.0.105 avoids executing commands built from untrusted configuration and properly validates/escapes inputs. Patches: Update to @anthropic-ai/claude-code 1.0.105 or later. Workarounds: Open only trusted workspaces and inspect repository .git/config before launch; avoid inheriting untrusted Git configuration values. Thank you to the NVIDIA AI Red Team for reporting this issue!

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-j4h9-wv2m-wrf7

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-j4h9-wv2m-wrf7

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-59041

Advisory: Claude Code vulnerable to arbitrary code execution caused by maliciously configured git email
IDs: CVE-2025-59041, GHSA-j4h9-wv2m-wrf7
Record: https://patchnext.com/advisories/cve-2025-59041 (revision 3, source checked 26 Oct 2026, 12:38 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @anthropic-ai/claude-code 1.0.105. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @anthropic-ai/claude-code: affected < 1.0.105; fixed in 1.0.105

## Suggested inspection (read-only)
- `npm ls @anthropic-ai/claude-code --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @anthropic-ai/claude-code.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-j4h9-wv2m-wrf7 (OSV record GHSA-j4h9-wv2m-wrf7 lists affected ranges: npm @anthropic-ai/claude-code >=0 <1.0.105 (fixed))
- Verified: https://github.com/advisories/GHSA-j4h9-wv2m-wrf7 (GitHub-reviewed advisory GHSA-j4h9-wv2m-wrf7 lists affected ranges: npm @anthropic-ai/claude-code >=0 <1.0.105)

Commands are suggestions: review each one before running it.

Loading voting…