Skip to content

← Actionable
Medium, CVSS 4.6amended

Indico vulnerable to Cross-Site Scripting via LaTeX math code

CVE-2025-59035GHSA-7cf7-9wrr-vrf4

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (indico 3.3.8), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI indico

    Affected
    <= 3.3.7
    Fixed in
    3.3.8

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
4.6 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:L/A:N
EPSS
  • CVE-2025-59035: 0.21% estimated exploitation activity in the next 30 days; percentile 10.68 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact There is a Cross-Site-Scripting vulnerability when rendering LaTeX math code in contribution or abstract descriptions. Patches You should to update to Indico 3.3.8 as soon as possible. See the docs for instructions on how to update. Workarounds Only let trustworthy users create content on Indico. Note that a conference doing a Call for Abstracts actively invites external speakers (who the organizers may not know and thus cannot fully trust) to submit content, hence the need to update to a a fixed version ASAP in particular when using such workflows. For more information If you have any questions or comments about this advisory: - Open a thread in our forum - Email us privately at indico-team@cern.ch

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-7cf7-9wrr-vrf4

  2. Revision 1 · created ·

    Published from osv record GHSA-7cf7-9wrr-vrf4

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-59035

Advisory: Indico vulnerable to Cross-Site Scripting via LaTeX math code
IDs: CVE-2025-59035, GHSA-7cf7-9wrr-vrf4
Record: https://patchnext.com/advisories/cve-2025-59035 (revision 2, source checked 26 Oct 2026, 13:35 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.6)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: indico 3.3.8. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI indico: affected <= 3.3.7; fixed in 3.3.8

## Suggested inspection (read-only)
- `python -m pip show indico`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on indico.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-7cf7-9wrr-vrf4 (OSV record GHSA-7cf7-9wrr-vrf4 lists affected ranges: PyPI indico >=0 <3.3.8 (fixed))
- Verified: https://github.com/advisories/GHSA-7cf7-9wrr-vrf4 (GitHub-reviewed advisory GHSA-7cf7-9wrr-vrf4 lists affected ranges: PyPI indico >=0 <=3.3.7)

Commands are suggestions: review each one before running it.

Loading voting…