Skip to content

← Actionable
Medium, CVSS 4.3amended

Indico may disclose unauthorized user details access via legacy API

CVE-2025-59034GHSA-4269-mcfh-cp7q

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (indico 3.3.8), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI indico

    Affected
    <= 3.3.7
    Fixed in
    3.3.8

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
4.3 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
EPSS
  • CVE-2025-59034: 0.26% estimated exploitation activity in the next 30 days; percentile 17.56 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact A legacy API to retrieve user details could be misused to retrieve profile details of other users without having admin permissions due to a broken access check. Patches You should to update to Indico 3.3.8 as soon as possible. See the docs for instructions on how to update. Workarounds It is possible to restrict access to the affected API (e.g. in the webserver config) which is most likely unused anyway and thus will not break anything. For more information If you have any questions or comments about this advisory: - Open a thread in our forum - Email us privately at indico-team@cern.ch

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-4269-mcfh-cp7q

  2. Revision 1 · created ·

    Published from osv record GHSA-4269-mcfh-cp7q

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-59034

Advisory: Indico may disclose unauthorized user details access via legacy API
IDs: CVE-2025-59034, GHSA-4269-mcfh-cp7q
Record: https://patchnext.com/advisories/cve-2025-59034 (revision 2, source checked 26 Oct 2026, 13:35 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: indico 3.3.8. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI indico: affected <= 3.3.7; fixed in 3.3.8

## Suggested inspection (read-only)
- `python -m pip show indico`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on indico.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-4269-mcfh-cp7q (OSV record GHSA-4269-mcfh-cp7q lists affected ranges: PyPI indico >=0 <3.3.8 (fixed))
- Verified: https://github.com/advisories/GHSA-4269-mcfh-cp7q (GitHub-reviewed advisory GHSA-4269-mcfh-cp7q lists affected ranges: PyPI indico >=0 <=3.3.7)

Commands are suggestions: review each one before running it.

Loading voting…