TYPO3 CMS uses insufficient entropy when generating passwords
CVE-2025-59015GHSA-p5jq-5383-qvc7
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (typo3/cms-core 13.4.18, 12.4.37), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist typo3/cms-core
- Affected
- >= 12.0.0, < 12.4.37>= 13.0.0, < 13.4.18
- Fixed in
- 13.4.18, 12.4.37
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-p5jq-5383-qvc7 lists affected ranges: Packagist typo3/cms-core >=12.0.0 =13.0.0 <13.4.18
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 6.3 · CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2025-59015: 0.19% estimated exploitation activity in the next 30 days; percentile 8.37 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
A deterministic three‑character prefix in the Password Generation component of TYPO3 CMS versions 12.0.0–12.4.36 and 13.0.0–13.4.17 reduces entropy, allowing attackers to carry out brute‑force attacks more quickly.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-p5jq-5383-qvc7
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-59015 Advisory: TYPO3 CMS uses insufficient entropy when generating passwords IDs: CVE-2025-59015, GHSA-p5jq-5383-qvc7 Record: https://patchnext.com/advisories/cve-2025-59015 (revision 1, source checked 26 Oct 2026, 14:34 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: typo3/cms-core 13.4.18, 12.4.37. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist typo3/cms-core: affected >= 12.0.0, < 12.4.37; >= 13.0.0, < 13.4.18; fixed in 13.4.18, 12.4.37 ## Suggested inspection (read-only) - Packagist typo3/cms-core: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on typo3/cms-core. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-p5jq-5383-qvc7 (GitHub-reviewed advisory GHSA-p5jq-5383-qvc7 lists affected ranges: Packagist typo3/cms-core >=12.0.0 =13.0.0 <13.4.18) Commands are suggestions: review each one before running it.
Loading voting…