auth0-PHP SDK Does Not Properly Handle File Types in Bulk User Import
CVE-2025-58769GHSA-9mh6-g99m-ppcw
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (auth0/auth0-php 8.17.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist auth0/auth0-php
- Affected
- >= 3.3.0, <= 8.16.0
- Fixed in
- 8.17.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-9mh6-g99m-ppcw lists affected ranges: Packagist auth0/auth0-php >=3.3.0 <=8.16.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 3.3 · CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:L/I:L/A:N
- EPSS
- CVE-2025-58769: 0.35% estimated exploitation activity in the next 30 days; percentile 28.72 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Overview In applications built with the Auth0-PHP SDK, the Bulk User Import endpoint does not validate the file path wrapper or value. Without proper validation, affected applications may accept arbitrary file paths or URLs. Am I affected? You are affected by this vulnerability if you meet the following preconditions: 1. Applications using the Auth0-PHP SDK, versions between v3.3.0 and v8.16.0, or 2. Applications using the following SDKs that rely on the Auth0-PHP SDK versions between v3.3.0 and v8.16.0: a. Auth0/symfony, b. Auth0/laravel-auth0, c. Auth0/wordpress. Fix Upgrade Auth0/Auth0-PHP to version 8.17.0 or greater. Acknowledgement Okta would like to thank Mohamed Amine Saidani (pwni) for discovering this vulnerability.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-9mh6-g99m-ppcw
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-58769 Advisory: auth0-PHP SDK Does Not Properly Handle File Types in Bulk User Import IDs: CVE-2025-58769, GHSA-9mh6-g99m-ppcw Record: https://patchnext.com/advisories/cve-2025-58769 (revision 1, source checked 26 Oct 2026, 14:34 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 3.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: auth0/auth0-php 8.17.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist auth0/auth0-php: affected >= 3.3.0, <= 8.16.0; fixed in 8.17.0 ## Suggested inspection (read-only) - Packagist auth0/auth0-php: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on auth0/auth0-php. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-9mh6-g99m-ppcw (GitHub-reviewed advisory GHSA-9mh6-g99m-ppcw lists affected ranges: Packagist auth0/auth0-php >=3.3.0 <=8.16.0) Commands are suggestions: review each one before running it.
Loading voting…