Skip to content

← Actionable
Medium, CVSS 5.1

TinyEnv: Missing .env file not required — may cause unexpected behavior

CVE-2025-58758GHSA-3j7m-5g4q-gfpc

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (datahihi1/tiny-env 1.0.11, 1.0.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.1 · CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N
EPSS
  • CVE-2025-58758: 0.19% estimated exploitation activity in the next 30 days; percentile 8.26 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact TinyEnv did not require the .env file to exist when loading environment variables. This could lead to unexpected behavior where the application silently ignores missing configuration, potentially causing insecure defaults or deployment misconfigurations. Affected versions: - 1.0.1 → 1.0.2 - 1.0.9 → 1.0.10 Patches The issue has been fixed in version 1.0.11. All users should upgrade to 1.0.11 or later. Workarounds As a workaround, users can manually verify the existence of the .env file before initializing TinyEnv, for example: php if (!fileexists(DIR . '/.env')) { throw new RuntimeException('.env file is missing!'); }

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-3j7m-5g4q-gfpc

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-58758

Advisory: TinyEnv: Missing .env file not required — may cause unexpected behavior
IDs: CVE-2025-58758, GHSA-3j7m-5g4q-gfpc
Record: https://patchnext.com/advisories/cve-2025-58758 (revision 1, source checked 26 Oct 2026, 14:34 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: datahihi1/tiny-env 1.0.11, 1.0.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist datahihi1/tiny-env: affected < 1.0.3; >= 1.0.9, < 1.0.11; fixed in 1.0.11, 1.0.3

## Suggested inspection (read-only)
- Packagist datahihi1/tiny-env: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on datahihi1/tiny-env.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-3j7m-5g4q-gfpc (GitHub-reviewed advisory GHSA-3j7m-5g4q-gfpc lists affected ranges: Packagist datahihi1/tiny-env >=0 =1.0.9 <1.0.11)

Commands are suggestions: review each one before running it.

Loading voting…