Skip to content

← Actionable
High, CVSS 8.8amended

MONAI does not prevent path traversal, potentially leading to arbitrary file writes

CVE-2025-58755GHSA-x6ww-pf9m-m73m

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (monai 1.5.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI monai

    Affected
    <= 1.5.0
    Fixed in
    1.5.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.8 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2025-58755: 0.62% estimated exploitation activity in the next 30 days; percentile 49.91 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The extractall function is used directly to process compressed files. It is used in many places in the project. When the Zip file containing malicious content is decompressed, it will overwrite the system files. In addition, the project allows the download of the zip content through the link, which increases the scope of exploitation of this vulnerability. When reproducing locally, follow the process below to create a malicious zip file and simulate the process of remotely downloading the zip file. Then start the http service through python Another terminal simulates a normal user downloading zip content from the Internet, perhaps from some popular forums or blogs, such as huggingface, etc. We can see that malicious.txt was indeed extracted to the root directory, demonstrating that the path traversal successfully wrote the malicious file. If the Zip file contains SSH keys, malicious content that automatically loads when the user boots the computer, or overwrites legitimate…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-x6ww-pf9m-m73m

  2. Revision 1 · created ·

    Published from osv record GHSA-x6ww-pf9m-m73m

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-58755

Advisory: MONAI does not prevent path traversal, potentially leading to arbitrary file writes
IDs: CVE-2025-58755, GHSA-x6ww-pf9m-m73m
Record: https://patchnext.com/advisories/cve-2025-58755 (revision 2, source checked 26 Oct 2026, 13:44 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: monai 1.5.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI monai: affected <= 1.5.0; fixed in 1.5.1

## Suggested inspection (read-only)
- `python -m pip show monai`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on monai.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-x6ww-pf9m-m73m (OSV record GHSA-x6ww-pf9m-m73m lists affected ranges: PyPI monai >=0 <1.5.1 (fixed))
- Verified: https://github.com/advisories/GHSA-x6ww-pf9m-m73m (GitHub-reviewed advisory GHSA-x6ww-pf9m-m73m lists affected ranges: PyPI monai >=0 <=1.5.0)

Commands are suggestions: review each one before running it.

Loading voting…