Vite's server.fs settings were not applied to HTML files
CVE-2025-58752GHSA-jqfw-vq24-v9c3
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (vite 7.1.5, 7.0.7, 6.3.6, 5.4.20), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm vite
- Affected
- >= 7.1.0, <= 7.1.4>= 7.0.0, <= 7.0.6>= 6.0.0, <= 6.3.5<= 5.4.19
- Fixed in
- 6.3.6, 7.1.5, 5.4.20, 7.0.7
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-jqfw-vq24-v9c3 lists affected ranges: npm vite >=7.1.0 =7.0.0 =6.0.0 =0 <5.4.20 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-jqfw-vq24-v9c3 lists affected ranges: npm vite >=7.1.0 =7.0.0 =6.0.0 =0 <=5.4.19
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 2.3 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2025-58752: 0.61% estimated exploitation activity in the next 30 days; percentile 49.14 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary Any HTML files on the machine were served regardless of the server.fs settings. Impact Only apps that match the following conditions are affected: - explicitly exposes the Vite dev server to the network (using --host or server.host config option) - appType: 'spa' (default) or appType: 'mpa' is used This vulnerability also affects the preview server. The preview server allowed HTML files not under the output directory to be served. Details The serveStaticMiddleware function is in charge of serving static files from the server. It returns the viteServeStaticMiddleware function which runs the needed tests and serves the page. The viteServeStaticMiddleware function checks if the extension of the requested file is ".html". If so, it doesn't serve the page. Instead, the server will go on to the next middlewares, in this case htmlFallbackMiddleware, and then to indexHtmlMiddleware. These middlewares don't perform any test against allow or deny rules, and they don't make sure that…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-jqfw-vq24-v9c3
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-jqfw-vq24-v9c3
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-58752 Advisory: Vite's `server.fs` settings were not applied to HTML files IDs: CVE-2025-58752, GHSA-jqfw-vq24-v9c3 Record: https://patchnext.com/advisories/cve-2025-58752 (revision 3, source checked 26 Oct 2026, 12:37 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 2.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: vite 7.1.5, 7.0.7, 6.3.6, 5.4.20. A vendor fix does not mean a deployment is fixed. ## Affected components - npm vite: affected >= 7.1.0, <= 7.1.4; >= 7.0.0, <= 7.0.6; >= 6.0.0, <= 6.3.5; <= 5.4.19; fixed in 6.3.6, 7.1.5, 5.4.20, 7.0.7 ## Suggested inspection (read-only) - `npm ls vite --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on vite. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-jqfw-vq24-v9c3 (OSV record GHSA-jqfw-vq24-v9c3 lists affected ranges: npm vite >=7.1.0 =7.0.0 =6.0.0 =0 <5.4.20 (fixed)) - Verified: https://github.com/advisories/GHSA-jqfw-vq24-v9c3 (GitHub-reviewed advisory GHSA-jqfw-vq24-v9c3 lists affected ranges: npm vite >=7.1.0 =7.0.0 =6.0.0 =0 <=5.4.19) Commands are suggestions: review each one before running it.
Loading voting…