Skip to content

← Actionable
High, CVSS 8.7amended

Cattown is Vulnerable to Uncontrolled Resource Consumption through Inefficient Regular Expression Complexity

CVE-2025-58451GHSA-455v-w7r9-3vv9

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (cattown 1.0.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm cattown

    Affected
    < 1.0.2
    Fixed in
    1.0.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2025-58451: 0.33% estimated exploitation activity in the next 30 days; percentile 26.88 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Overview A security review of the Cattown identified multiple weaknesses that could potentially impact its stability and security. Affected Versions - All versions below 1.0.2 Description of Vulnerabilities 1. CWE-1333: Inefficient Regular Expression Complexity The package used regular expressions with inefficient, potentially exponential worst-case complexity. This can cause excessive CPU usage due to excessive backtracking on crafted inputs, potentially leading to denial of service. 2. CWE-400: Uncontrolled Resource Consumption (Resource Exhaustion) The package was vulnerable to resource exhaustion, where processing malicious inputs could cause high CPU or memory usage, potentially leading to denial of service. Impact - Trigger excessive CPU consumption leading to denial of service - Cause resource exhaustion affecting service availability - Bypass protection mechanisms causing unexpected or insecure behavior Resolution These vulnerabilities have been fixed in version 1.0.2 of the…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-455v-w7r9-3vv9

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-455v-w7r9-3vv9

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-58451

Advisory: Cattown is Vulnerable to Uncontrolled Resource Consumption through Inefficient Regular Expression Complexity
IDs: CVE-2025-58451, GHSA-455v-w7r9-3vv9
Record: https://patchnext.com/advisories/cve-2025-58451 (revision 3, source checked 26 Oct 2026, 12:38 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: cattown 1.0.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm cattown: affected < 1.0.2; fixed in 1.0.2

## Suggested inspection (read-only)
- `npm ls cattown --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on cattown.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-455v-w7r9-3vv9 (OSV record GHSA-455v-w7r9-3vv9 lists affected ranges: npm cattown >=0 <1.0.2 (fixed))
- Verified: https://github.com/advisories/GHSA-455v-w7r9-3vv9 (GitHub-reviewed advisory GHSA-455v-w7r9-3vv9 lists affected ranges: npm cattown >=0 <1.0.2)

Commands are suggestions: review each one before running it.

Loading voting…