Skip to content

← Actionable
High, CVSS 8.7

Maho is Vulnerable to Authenticated Remote Code Execution via File Upload

CVE-2025-58449GHSA-vgmm-27fc-vmgp

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (mahocommerce/maho 25.9.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.7 · CVSS:4.0/AV:N/AC:L/AT:P/PR:H/UI:A/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H · score source
EPSS
  • CVE-2025-58449: 0.31% estimated exploitation activity in the next 30 days; percentile 23.58 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary In Maho 25.7.0, an authenticated staff user with access to the Dashboard and Catalog\Manage Products permissions can create a custom option on a listing with a file input field. By allowing file uploads with a .php extension, the user can use the filed to upload malicious PHP files, gaining remote code execution Details An user with the Dashboard and Catalog\Manage Products permissions can abuse the product custom options feature to bypass the application’s file upload restrictions. When creating a product custom option of type file upload, the user is allowed to define their own extension whitelist. This bypasses the application’s normal enforced whitelist and permits disallowed extensions, including .php. The file uploaded by the custom option is then written to a predictable location: Because this path is directly accessible under the application’s webroot, an attacker can then request the uploaded file via HTTP, causing the server to execute the PHP payload. PoC 1. Sign…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-vgmm-27fc-vmgp

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-58449

Advisory: Maho is Vulnerable to Authenticated Remote Code Execution via File Upload
IDs: CVE-2025-58449, GHSA-vgmm-27fc-vmgp
Record: https://patchnext.com/advisories/cve-2025-58449 (revision 1, source checked 26 Oct 2026, 14:34 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: mahocommerce/maho 25.9.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist mahocommerce/maho: affected < 25.9.0; fixed in 25.9.0

## Suggested inspection (read-only)
- Packagist mahocommerce/maho: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on mahocommerce/maho.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-vgmm-27fc-vmgp (GitHub-reviewed advisory GHSA-vgmm-27fc-vmgp lists affected ranges: Packagist mahocommerce/maho >=0 <25.9.0)

Commands are suggestions: review each one before running it.

Loading voting…