Skip to content

← Actionable
Medium, CVSS 6.9amended

xgrammar vulnerable to denial of service by huge enum grammar

CVE-2025-58446GHSA-9q5r-wfvf-rr7f

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (xgrammar 0.1.24), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI xgrammar

    Affected
    >= 0.1.23, <= 0.1.23
    Fixed in
    0.1.24

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
6.9 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X · score source
EPSS
  • CVE-2025-58446: 0.62% estimated exploitation activity in the next 30 days; percentile 49.70 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Provided grammar, would fit in a context window of most of the models, but takes minutes to process in 0.1.23. In testing with 0.1.16 the parser worked fine so this seems to be a regression caused by Earley parser. Details Full reproducer provider in the POC section. The resulting grammar is around 70k tokens, and the grammar parsing itself (with the models I checked) was significantly longer than LLM processing itself, meaning this can be used to DOS model providers. Patch This problem is caused by the grammar optimizer introduced in v0.1.23 being too slow. It only happens for very large grammars (100k characters), like the below one. v0.1.24 solved this problem by optimizing the speed of the grammar optimizer and disable some slow optimization for large grammars. Thanks to @Seven-Streams PoC where: Impact DOS

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-9q5r-wfvf-rr7f

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-9q5r-wfvf-rr7f

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-58446

Advisory: xgrammar vulnerable to denial of service by huge enum grammar
IDs: CVE-2025-58446, GHSA-9q5r-wfvf-rr7f
Record: https://patchnext.com/advisories/cve-2025-58446 (revision 3, source checked 26 Oct 2026, 13:35 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: xgrammar 0.1.24. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI xgrammar: affected >= 0.1.23, <= 0.1.23; fixed in 0.1.24

## Suggested inspection (read-only)
- `python -m pip show xgrammar`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on xgrammar.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-9q5r-wfvf-rr7f (OSV record GHSA-9q5r-wfvf-rr7f lists affected ranges: PyPI xgrammar >=0.1.23 <0.1.24 (fixed))
- Verified: https://github.com/advisories/GHSA-9q5r-wfvf-rr7f (GitHub-reviewed advisory GHSA-9q5r-wfvf-rr7f lists affected ranges: PyPI xgrammar >=0.1.23 <=0.1.23)

Commands are suggestions: review each one before running it.

Loading voting…