Skip to content

← Actionable
Critical, CVSS 9.4amended

internetarchive Vulnerable to Directory Traversal in File.download()

CVE-2025-58438GHSA-wx3r-v6h7-frjp

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (internetarchive 5.5.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
9.4 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X · score source
EPSS
  • CVE-2025-58438: 1.59% estimated exploitation activity in the next 30 days; percentile 75.68 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact What kind of vulnerability is it? This is a Critical severity directory traversal (path traversal) vulnerability in the `File.download()` method of the `internetarchive` library. Who is impacted? All users of the `internetarchive` library versions `< 5.5.1` are impacted. The vulnerability is particularly critical for users on Windows systems, but all operating systems are affected. Description of the vulnerability: The vulnerability existed because the `file.download()` method did not properly sanitize user-supplied filenames or validate the final download path. A maliciously crafted filename could contain path traversal sequences (e.g., `../../../../windows/system32/file.txt`) or illegal characters that, when processed, would cause the file to be written outside of the intended target directory. Potential Impact: An attacker could potentially overwrite critical system files or application configuration files, leading to a denial of service,…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 5 · amended ·

    Amended from osv record GHSA-wx3r-v6h7-frjp

  2. Revision 4 · amended ·

    Amended from ghsa record GHSA-wx3r-v6h7-frjp

  3. Revision 3 · amended ·

    Amended from ghsa record GHSA-wx3r-v6h7-frjp

  4. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  5. Revision 1 · created ·

    Published from osv record GHSA-wx3r-v6h7-frjp

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-58438

Advisory: internetarchive Vulnerable to Directory Traversal in File.download()
IDs: CVE-2025-58438, GHSA-wx3r-v6h7-frjp
Record: https://patchnext.com/advisories/cve-2025-58438 (revision 5, source checked 28 Oct 2026, 06:05 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: internetarchive 5.5.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI internetarchive: affected < 5.5.1; fixed in 5.5.1

## Suggested inspection (read-only)
- `python -m pip show internetarchive`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on internetarchive.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-wx3r-v6h7-frjp (OSV record GHSA-wx3r-v6h7-frjp lists affected ranges: PyPI internetarchive >=0 <5.5.1 (fixed))
- Verified: https://github.com/advisories/GHSA-wx3r-v6h7-frjp (GitHub-reviewed advisory GHSA-wx3r-v6h7-frjp lists affected ranges: PyPI internetarchive >=0 <=5.5.0)

Commands are suggestions: review each one before running it.

Loading voting…