Coder vulnerable to privilege escalation could lead to a cross workspace compromise
CVE-2025-58437GHSA-j6xf-jwrj-v5qp
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/coder/coder/v2 2.25.2, 2.24.4), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- >= 2.22.0, < 2.24.4>= 2.25.0, < 2.25.2
- Fixed in
- 2.24.4, 2.25.2
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-j6xf-jwrj-v5qp lists affected ranges: Go github.com/coder/coder/v2 >=2.22.0 =2.25.0 <2.25.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.1 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N
- EPSS
- CVE-2025-58437: 0.40% estimated exploitation activity in the next 30 days; percentile 33.86 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary Insecure session handling opened room for a privilege escalation scenario in which prebuilt workspaces could be compromised by abusing a shared system identity. Details Coder automatically generates a session token for a user when a workspace is started. It is automatically exposed via coderworkspaceowner.sessiontoken. Prebuilt workspaces are initially owned by a built-in prebuilds system user. When a prebuilt workspace is claimed, a new session token is generated for the user that claimed the workspace, but the previous session token for the prebuilds user was not expired. Any Coder workspace templates that persist this automatically generated session token are potentially impacted. For example, the coder-login module allows template authors to automatically configure the coder CLI to be authenticated with the Coder deployment. This causes a script to be run on workspace startup that runs the command coder login using the automatically generated user session token c.f.…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-j6xf-jwrj-v5qp
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-58437 Advisory: Coder vulnerable to privilege escalation could lead to a cross workspace compromise IDs: CVE-2025-58437, GHSA-j6xf-jwrj-v5qp Record: https://patchnext.com/advisories/cve-2025-58437 (revision 1, source checked 26 Oct 2026, 15:10 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/coder/coder/v2 2.25.2, 2.24.4. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/coder/coder/v2: affected >= 2.22.0, < 2.24.4; >= 2.25.0, < 2.25.2; fixed in 2.24.4, 2.25.2 ## Suggested inspection (read-only) - Go github.com/coder/coder/v2: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/coder/coder/v2. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-j6xf-jwrj-v5qp (GitHub-reviewed advisory GHSA-j6xf-jwrj-v5qp lists affected ranges: Go github.com/coder/coder/v2 >=2.22.0 =2.25.0 <2.25.2) Commands are suggestions: review each one before running it.
Loading voting…