Skip to content

← Actionable
Critical, CVSS 10.0amended

DeepDiff Class Pollution in Delta class leading to DoS, Remote Code Execution, and more

CVE-2025-58367GHSA-mw26-5g2v-hqw3

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (deepdiff 8.6.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI deepdiff

    Affected
    >= 5.0.0, < 8.6.1
    Fixed in
    8.6.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
10.0 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H · score source
EPSS
  • CVE-2025-58367: 1.19% estimated exploitation activity in the next 30 days; percentile 67.94 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Python class pollution is a novel vulnerability categorized under CWE-915. The `Delta` class is vulnerable to class pollution via its constructor, and when combined with a gadget available in DeltaDiff itself, it can lead to Denial of Service and Remote Code Execution (via insecure Pickle deserialization). The gadget available in DeepDiff allows `deepdiff.serialization.SAFE_TO_IMPORT` to be modified to allow dangerous classes such as `posix.system`, and then perform insecure Pickle deserialization via the Delta class. This potentially allows any Python code to be executed, given that the input to `Delta` is user-controlled. Depending on the application where DeepDiff is used, this can also lead to other vulnerabilities. For example, in a web application, it might be possible to bypass authentication via class…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 5 · amended ·

    Amended from osv record GHSA-mw26-5g2v-hqw3

  2. Revision 4 · amended ·

    Amended from ghsa record GHSA-mw26-5g2v-hqw3

  3. Revision 3 · amended ·

    Amended from ghsa record GHSA-mw26-5g2v-hqw3

  4. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  5. Revision 1 · created ·

    Published from osv record GHSA-mw26-5g2v-hqw3

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-58367

Advisory: DeepDiff Class Pollution in Delta class leading to DoS, Remote Code Execution, and more
IDs: CVE-2025-58367, GHSA-mw26-5g2v-hqw3
Record: https://patchnext.com/advisories/cve-2025-58367 (revision 5, source checked 28 Oct 2026, 06:10 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 10.0)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: deepdiff 8.6.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI deepdiff: affected >= 5.0.0, < 8.6.1; fixed in 8.6.1

## Suggested inspection (read-only)
- `python -m pip show deepdiff`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on deepdiff.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-mw26-5g2v-hqw3 (OSV record GHSA-mw26-5g2v-hqw3 lists affected ranges: PyPI deepdiff >=5.0.0 <8.6.1 (fixed))
- Verified: https://github.com/advisories/GHSA-mw26-5g2v-hqw3 (GitHub-reviewed advisory GHSA-mw26-5g2v-hqw3 lists affected ranges: PyPI deepdiff >=5.0.0 <=8.6.0)
- Verified: https://github.com/advisories/GHSA-mw26-5g2v-hqw3 (GitHub-reviewed advisory GHSA-mw26-5g2v-hqw3 lists affected ranges: PyPI deepdiff >=5.0.0 <8.6.1)

Commands are suggestions: review each one before running it.

Loading voting…