Skip to content

← Actionable
High, CVSS 8.2Exploited · CISA KEV

GeoServer is vulnerable to Unauthenticated XML External Entities (XXE) attack via WMS GetMap feature

CVE-2025-58360GHSA-fjf5-xgmq-5525

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.geoserver.web:gs-web-app 2.26.2, 2.25.6; org.geoserver:gs-wms 2.26.2, 2.25.6), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
Confirmed: listed in the CISA Known Exploited Vulnerabilities catalog.
CVSS
8.2 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:L
EPSS
  • CVE-2025-58360: 61.17% estimated exploitation activity in the next 30 days; percentile 99.16 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Description An XML External Entity (XXE) vulnerability was identified. The application accepts XML input through a specific endpoint /geoserver/wms operation GetMap. However, this input is not sufficiently sanitized or restricted, allowing an attacker to define external entities within the XML request. An XML External Entity attack is a type of attack that occurs when XML input containing a reference to an external entity is processed by a weakly configured XML parser. This attack may lead to the disclosure of confidential data, denial of service, port scanning from the perspective of the machine where the parser is located, and other system impacts. By exploiting this vulnerability, an attacker can: - Read arbitrary files from the server's file system. - Conduct Server-Side Request Forgery (SSRF) to interact with internal systems. - Execute Denial of Service (DoS) attacks by exhausting resources. Resolution Update to GeoServer 2.25.6, GeoServer 2.26.3, or GeoServer 2.27.0. Impact…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-fjf5-xgmq-5525

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-58360

Advisory: GeoServer is vulnerable to Unauthenticated XML External Entities (XXE) attack via WMS GetMap feature
IDs: CVE-2025-58360, GHSA-fjf5-xgmq-5525
Record: https://patchnext.com/advisories/cve-2025-58360 (revision 1, source checked 26 Oct 2026, 16:43 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.2)
Exploitation: confirmed: listed in the CISA Known Exploited Vulnerabilities catalog.
Vendor response: Vendor fix available; fixed versions by package: org.geoserver.web:gs-web-app 2.26.2, 2.25.6; org.geoserver:gs-wms 2.26.2, 2.25.6. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.geoserver.web:gs-web-app: affected >= 2.26.0, < 2.26.2; < 2.25.6; fixed in 2.26.2, 2.25.6
- Maven org.geoserver:gs-wms: affected >= 2.26.0, < 2.26.2; < 2.25.6; fixed in 2.26.2, 2.25.6

## Suggested inspection (read-only)
- Maven org.geoserver.web:gs-web-app: check the installed version with your package manager.
- Maven org.geoserver:gs-wms: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.geoserver.web:gs-web-app, org.geoserver:gs-wms.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-fjf5-xgmq-5525 (GitHub-reviewed advisory GHSA-fjf5-xgmq-5525 lists affected ranges: Maven org.geoserver.web:gs-web-app >=2.26.0 =0 =2.26.0 =0 <2.25.6)
- Verified: https://www.cisa.gov/known-exploited-vulnerabilities-catalog (CISA added CVE-2025-58360 to the Known Exploited Vulnerabilities catalog on 2025-12-11.)

Commands are suggestions: review each one before running it.

Loading voting…