Skip to content

← Actionable
Medium, CVSS 6.0

frost-core: refresh shares with smaller min_signers will reduce security of group

CVE-2025-58359GHSA-wgq8-vr6r-mqxm

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (frost-core 2.2.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • crates.io frost-core

    Affected
    >= 2.0.0, < 2.2.0
    Fixed in
    2.2.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
6.0 · CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2025-58359: 0.29% estimated exploitation activity in the next 30 days; percentile 21.92 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact It was not clear that it is not possible to change minsigners (i.e. the threshold) with the refresh share functionality (frostcore::keys::refresh module). Using a smaller value would not decrease the threshold, and attempts to sign using a smaller threshold would fail. Additionally, after refreshing the shares with a smaller threshold, it would still be possible to sign with the original threshold; however, this could cause a security loss to the participant's shares. We have not determined the exact security implications of doing so and judged simpler to just validate minsigners. If for some reason you have done a refresh share procedure with a smaller minsigners we strongly recommend migrating to a new key. Patches Updating to 2.2.0 will ensure that the minsigners parameter will be validated. However it won't restore the security of groups refreshed with a smaller minsigners parameters. Workarounds You don't need to update if you don't use the refresh share functionality, or…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-wgq8-vr6r-mqxm

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-58359

Advisory: frost-core: refresh shares with smaller min_signers will reduce security of group
IDs: CVE-2025-58359, GHSA-wgq8-vr6r-mqxm
Record: https://patchnext.com/advisories/cve-2025-58359 (revision 1, source checked 26 Oct 2026, 15:39 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.0)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: frost-core 2.2.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- crates.io frost-core: affected >= 2.0.0, < 2.2.0; fixed in 2.2.0

## Suggested inspection (read-only)
- crates.io frost-core: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on frost-core.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-wgq8-vr6r-mqxm (GitHub-reviewed advisory GHSA-wgq8-vr6r-mqxm lists affected ranges: crates.io frost-core >=2.0.0 <2.2.0)

Commands are suggestions: review each one before running it.

Loading voting…