Soft Serve vulnerable to arbitrary file writing through SSH API
CVE-2025-58355GHSA-33pr-m977-5w97
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/charmbracelet/soft-serve 0.10.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go github.com/charmbracelet/soft-serve
- Affected
- < 0.10.0
- Fixed in
- 0.10.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-33pr-m977-5w97 lists affected ranges: Go github.com/charmbracelet/soft-serve >=0 <0.10.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.7 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:N/I:H/A:N
- EPSS
- CVE-2025-58355: 0.34% estimated exploitation activity in the next 30 days; percentile 28.11 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Attackers can create/override arbitrary files with uncontrolled data. For a PoC, spin up an instance of soft-serve as explained in the README, and execute the following command: It should have created a file in /tmp/pwned.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-33pr-m977-5w97
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-58355 Advisory: Soft Serve vulnerable to arbitrary file writing through SSH API IDs: CVE-2025-58355, GHSA-33pr-m977-5w97 Record: https://patchnext.com/advisories/cve-2025-58355 (revision 1, source checked 26 Oct 2026, 15:10 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/charmbracelet/soft-serve 0.10.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/charmbracelet/soft-serve: affected < 0.10.0; fixed in 0.10.0 ## Suggested inspection (read-only) - Go github.com/charmbracelet/soft-serve: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/charmbracelet/soft-serve. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-33pr-m977-5w97 (GitHub-reviewed advisory GHSA-33pr-m977-5w97 lists affected ranges: Go github.com/charmbracelet/soft-serve >=0 <0.10.0) Commands are suggestions: review each one before running it.
Loading voting…