Weblate has a long session expiry when verifying second factor
CVE-2025-58352GHSA-377j-wj38-4728
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (weblate 5.13.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI weblate
- Affected
- < 5.13.1
- Fixed in
- 5.13.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-377j-wj38-4728 lists affected ranges: PyPI weblate >=0 <5.13.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-377j-wj38-4728 lists affected ranges: PyPI weblate >=0 <5.13.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 2.1 · CVSS:4.0/AV:N/AC:H/AT:P/PR:L/UI:P/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2025-58352: 0.29% estimated exploitation activity in the next 30 days; percentile 21.61 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact The verification of the second factor had too long a session expiry. The long session expiry could be used to circumvent rate limiting of the second factor. Patches This issue has been addressed in Weblate 5.13.1 via https://github.com/WeblateOrg/weblate/pull/16002. References Thanks to Nahid Hasan Limon for reporting this issue responsibly.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-377j-wj38-4728
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-377j-wj38-4728
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-58352 Advisory: Weblate has a long session expiry when verifying second factor IDs: CVE-2025-58352, GHSA-377j-wj38-4728 Record: https://patchnext.com/advisories/cve-2025-58352 (revision 3, source checked 26 Oct 2026, 13:35 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 2.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: weblate 5.13.1. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI weblate: affected < 5.13.1; fixed in 5.13.1 ## Suggested inspection (read-only) - `python -m pip show weblate`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on weblate. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-377j-wj38-4728 (OSV record GHSA-377j-wj38-4728 lists affected ranges: PyPI weblate >=0 <5.13.1 (fixed)) - Verified: https://github.com/advisories/GHSA-377j-wj38-4728 (GitHub-reviewed advisory GHSA-377j-wj38-4728 lists affected ranges: PyPI weblate >=0 <5.13.1) Commands are suggestions: review each one before running it.
Loading voting…