Apache Doris-MCP-Server: Improper Access Control results in bypassing a "read-only" mode
CVE-2025-58337GHSA-m35w-xx8c-6xc7
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (doris-mcp-server 0.6.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI doris-mcp-server
- Affected
- < 0.6.0
- Fixed in
- 0.6.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-m35w-xx8c-6xc7 lists affected ranges: PyPI doris-mcp-server >=0 <0.6.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-m35w-xx8c-6xc7 lists affected ranges: PyPI doris-mcp-server >=0 <0.6.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 5.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2025-58337: 0.37% estimated exploitation activity in the next 30 days; percentile 31.17 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
An attacker with a valid read-only account can bypass Doris MCP Server’s read-only mode due to improper access control, allowing modifications that should have been prevented by read-only restrictions. Impact: Bypasses read-only mode; attackers with read-only access may perform unauthorized modifications. Recommended action for operators: Upgrade to version 0.6.0 as soon as possible (this release contains the fix).
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-m35w-xx8c-6xc7
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-m35w-xx8c-6xc7
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-58337 Advisory: Apache Doris-MCP-Server: Improper Access Control results in bypassing a "read-only" mode IDs: CVE-2025-58337, GHSA-m35w-xx8c-6xc7 Record: https://patchnext.com/advisories/cve-2025-58337 (revision 3, source checked 26 Oct 2026, 13:35 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: doris-mcp-server 0.6.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI doris-mcp-server: affected < 0.6.0; fixed in 0.6.0 ## Suggested inspection (read-only) - `python -m pip show doris-mcp-server`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on doris-mcp-server. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-m35w-xx8c-6xc7 (OSV record GHSA-m35w-xx8c-6xc7 lists affected ranges: PyPI doris-mcp-server >=0 <0.6.0 (fixed)) - Verified: https://github.com/advisories/GHSA-m35w-xx8c-6xc7 (GitHub-reviewed advisory GHSA-m35w-xx8c-6xc7 lists affected ranges: PyPI doris-mcp-server >=0 <0.6.0) Commands are suggestions: review each one before running it.
Loading voting…