OctoPrint is Vulnerable to RCE Attacks via Unsanitized Filename in File Upload
CVE-2025-58180GHSA-49mj-x8jp-qvfc
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (octoprint 1.11.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI octoprint
- Affected
- < 1.11.3
- Fixed in
- 1.11.3
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-49mj-x8jp-qvfc lists affected ranges: PyPI octoprint >=0 <1.11.3 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-49mj-x8jp-qvfc lists affected ranges: PyPI octoprint >=0 <1.11.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 7.5 · CVSS:4.0/AV:A/AC:L/AT:P/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2025-58180: 22.14% estimated exploitation activity in the next 30 days; percentile 97.67 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact OctoPrint versions up until and including 1.11.2 contain a vulnerability that allows an authenticated attacker to upload a file under a specially crafted filename that will allow arbitrary command execution if said filename becomes included in a command defined in a system event handler and said event gets triggered. If no event handlers executing system commands with uploaded filenames as parameters have been configured, this vulnerability does not have an impact. Patches The vulnerability will be patched in version 1.11.3. Workaround Until the patch has been applied, OctoPrint administrators who have event handlers configured that include any kind of filename based placeholders (i.e. {filename}, {filepath}, {filename}, {path}, etc -- refer to the events documentation for a full list) should disable those by setting their enabled property to False or unchecking the "Enabled" checkbox in the GUI based Event Manager. Alternatively, OctoPrint administrators should set…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-49mj-x8jp-qvfc
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-49mj-x8jp-qvfc
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-58180 Advisory: OctoPrint is Vulnerable to RCE Attacks via Unsanitized Filename in File Upload IDs: CVE-2025-58180, GHSA-49mj-x8jp-qvfc Record: https://patchnext.com/advisories/cve-2025-58180 (revision 3, source checked 26 Oct 2026, 13:35 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: octoprint 1.11.3. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI octoprint: affected < 1.11.3; fixed in 1.11.3 ## Suggested inspection (read-only) - `python -m pip show octoprint`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on octoprint. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-49mj-x8jp-qvfc (OSV record GHSA-49mj-x8jp-qvfc lists affected ranges: PyPI octoprint >=0 <1.11.3 (fixed)) - Verified: https://github.com/advisories/GHSA-49mj-x8jp-qvfc (GitHub-reviewed advisory GHSA-49mj-x8jp-qvfc lists affected ranges: PyPI octoprint >=0 <1.11.3) Commands are suggestions: review each one before running it.
Loading voting…