Skip to content

← Actionable
Medium, CVSS 4.1amended

Stored XSS in n8n LangChain Chat Trigger Node via initialMessages Parameter

CVE-2025-58177GHSA-mvh4-2cm2-6hpg

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (n8n 1.107.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm n8n

    Affected
    >= 1.24.0, < 1.107.0
    Fixed in
    1.107.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
4.1 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:N/A:N
EPSS
  • CVE-2025-58177: 0.24% estimated exploitation activity in the next 30 days; percentile 15.59 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact A stored Cross-Site Scripting (XSS) vulnerability was identified in the @n8n/n8n-nodes-langchain.chatTrigger node in n8n. If an authorized user configures the node with malicious JavaScript in the initialMessages field and enables public access, the script will be executed in the browser of anyone who visits the resulting public chat URL. This vulnerability could be exploited for phishing or to steal cookies or other sensitive data from users who access the public chat link, posing a security risk. Patches This issue has been patched in version 1.107.0 of n8n. Users should upgrade to version 1.107.0 or later. Workarounds Disabling the n8n-nodes-langchain.chatTrigger node (docs) References #18148

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-mvh4-2cm2-6hpg

  2. Revision 1 · created ·

    Published from osv record GHSA-mvh4-2cm2-6hpg

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-58177

Advisory: Stored XSS in n8n LangChain Chat Trigger Node via initialMessages Parameter
IDs: CVE-2025-58177, GHSA-mvh4-2cm2-6hpg
Record: https://patchnext.com/advisories/cve-2025-58177 (revision 2, source checked 26 Oct 2026, 12:37 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: n8n 1.107.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm n8n: affected >= 1.24.0, < 1.107.0; fixed in 1.107.0

## Suggested inspection (read-only)
- `npm ls n8n --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on n8n.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-mvh4-2cm2-6hpg (OSV record GHSA-mvh4-2cm2-6hpg lists affected ranges: npm n8n >=1.24.0 <1.107.0 (fixed))
- Verified: https://github.com/advisories/GHSA-mvh4-2cm2-6hpg (GitHub-reviewed advisory GHSA-mvh4-2cm2-6hpg lists affected ranges: npm n8n >=1.24.0 <1.107.0)

Commands are suggestions: review each one before running it.

Loading voting…