GeoServer has a Server-Side Request Forgery (SSRF) Vulnerability in its XML Entity Resolution
CVE-2025-58175GHSA-x4r9-gmw3-hxww
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.geoserver:gs-main 2.27.3, 2.26.4; org.geoserver.web:gs-web-app 2.27.3, 2.26.4), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.geoserver:gs-main
- Affected
- <= 2.26.3>= 2.27.0, <= 2.27.2
- Fixed in
- 2.27.3, 2.26.4
Maven org.geoserver.web:gs-web-app
- Affected
- <= 2.26.3>= 2.27.0, <= 2.27.2
- Fixed in
- 2.27.3, 2.26.4
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-x4r9-gmw3-hxww lists affected ranges: Maven org.geoserver.web:gs-web-app >=0 =2.27.0 =0 =2.27.0 <=2.27.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.5 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:L
- EPSS
- CVE-2025-58175: 0.29% estimated exploitation activity in the next 30 days; percentile 21.28 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary A GeoServer that uses ENTITYRESOLUTIONALLOWLIST may allow attacker to perform unauthenticated Server-Side Request Forgery (SSRF). Details This vulnerability requires that GeoServer is set up to use a proxy base URL and the ENTITYRESOLUTIONALLOWLIST (default since 2.25.0): Impact This vulnerability allows an attacker to cause GeoServer to make requests to an unintended location. Workaround GeoServer installations are only affected by this vulnerability if they use a proxy base URL that does not contain a URL path or end with a slash (e.g., https://somesite.org instead of https://somesite.org/ or https://somesite.org/geoserver). If the proxy base URL does not contain a path, adding a slash to the end of the URL will mitigate this vulnerability. Resources https://osgeo-org.atlassian.net/browse/GEOS-11867 https://github.com/geoserver/geoserver/pull/8622 Credits: - Le Mau Anh Phong at Verichains Cyber Force
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-x4r9-gmw3-hxww
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-58175 Advisory: GeoServer has a Server-Side Request Forgery (SSRF) Vulnerability in its XML Entity Resolution IDs: CVE-2025-58175, GHSA-x4r9-gmw3-hxww Record: https://patchnext.com/advisories/cve-2025-58175 (revision 1, source checked 26 Oct 2026, 16:46 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.geoserver:gs-main 2.27.3, 2.26.4; org.geoserver.web:gs-web-app 2.27.3, 2.26.4. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.geoserver:gs-main: affected <= 2.26.3; >= 2.27.0, <= 2.27.2; fixed in 2.27.3, 2.26.4 - Maven org.geoserver.web:gs-web-app: affected <= 2.26.3; >= 2.27.0, <= 2.27.2; fixed in 2.27.3, 2.26.4 ## Suggested inspection (read-only) - Maven org.geoserver:gs-main: check the installed version with your package manager. - Maven org.geoserver.web:gs-web-app: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.geoserver:gs-main, org.geoserver.web:gs-web-app. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-x4r9-gmw3-hxww (GitHub-reviewed advisory GHSA-x4r9-gmw3-hxww lists affected ranges: Maven org.geoserver.web:gs-web-app >=0 =2.27.0 =0 =2.27.0 <=2.27.2) Commands are suggestions: review each one before running it.
Loading voting…