Mattermost has a Missing Authorization vulnerability
CVE-2025-58075GHSA-r6qj-894f-5hr2
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/mattermost/mattermost/server/v8 8.0.0-20250815100400-2d5cdc6e217e; github.com/mattermost/mattermost-server 10.11.2, 10.10.3, 10.5.11), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go github.com/mattermost/mattermost/server/v8
- Affected
- < 8.0.0-20250815100400-2d5cdc6e217e
- Fixed in
- 8.0.0-20250815100400-2d5cdc6e217e
Go github.com/mattermost/mattermost-server
- Affected
- >= 10.11.0, < 10.11.2>= 10.10.0, < 10.10.3>= 10.5.0, < 10.5.11
- Fixed in
- 10.10.3, 10.5.11, 10.11.2
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-r6qj-894f-5hr2 lists affected ranges: Go github.com/mattermost/mattermost/server/v8 >=0 =10.11.0 =10.10.0 =10.5.0 <10.5.11
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.1 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N
- EPSS
- CVE-2025-58075: 0.34% estimated exploitation activity in the next 30 days; percentile 27.11 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Mattermost versions 10.11.x <= 10.11.1, 10.10.x <= 10.10.2, 10.5.x <= 10.5.10 fail to verify a user has permission to join a Mattermost team using the original invite token which allows any attacked to join any team on a Mattermost server regardless of restrictions via manipulating the RelayState.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-r6qj-894f-5hr2
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-58075 Advisory: Mattermost has a Missing Authorization vulnerability IDs: CVE-2025-58075, GHSA-r6qj-894f-5hr2 Record: https://patchnext.com/advisories/cve-2025-58075 (revision 1, source checked 26 Oct 2026, 15:13 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/mattermost/mattermost/server/v8 8.0.0-20250815100400-2d5cdc6e217e; github.com/mattermost/mattermost-server 10.11.2, 10.10.3, 10.5.11. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/mattermost/mattermost/server/v8: affected < 8.0.0-20250815100400-2d5cdc6e217e; fixed in 8.0.0-20250815100400-2d5cdc6e217e - Go github.com/mattermost/mattermost-server: affected >= 10.11.0, < 10.11.2; >= 10.10.0, < 10.10.3; >= 10.5.0, < 10.5.11; fixed in 10.10.3, 10.5.11, 10.11.2 ## Suggested inspection (read-only) - Go github.com/mattermost/mattermost/server/v8: check the installed version with your package manager. - Go github.com/mattermost/mattermost-server: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/mattermost/mattermost/server/v8, github.com/mattermost/mattermost-server. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-r6qj-894f-5hr2 (GitHub-reviewed advisory GHSA-r6qj-894f-5hr2 lists affected ranges: Go github.com/mattermost/mattermost/server/v8 >=0 =10.11.0 =10.10.0 =10.5.0 <10.5.11) Commands are suggestions: review each one before running it.
Loading voting…