Skip to content

← Actionable
Medium, CVSS 6.3amended

Eventlet affected by HTTP request smuggling in unparsed trailers

CVE-2025-58068GHSA-hw6f-rjfj-j7j7

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (eventlet 0.40.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI eventlet

    Affected
    < 0.40.3
    Fixed in
    0.40.3

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
6.3 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N · score source
EPSS
  • CVE-2025-58068: 0.42% estimated exploitation activity in the next 30 days; percentile 36.37 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact The Eventlet WSGI parser is vulnerable to HTTP Request Smuggling due to improper handling of HTTP trailer sections. This vulnerability could enable attackers to: - Bypass front-end security controls - Launch targeted attacks against active site users - Poison web caches Patches Problem has been patched in eventlet 0.40.3. The patch just drops trailers. If a backend behind eventlet.wsgi proxy requires trailers, then this patch BREAKS your setup. Workarounds Do not use eventlet.wsgi facing untrusted clients. References - Patch https://github.com/eventlet/eventlet/pull/1062 - This issue is similar to https://github.com/advisories/GHSA-9548-qrrj-x5pj

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-hw6f-rjfj-j7j7

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-hw6f-rjfj-j7j7

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-58068

Advisory: Eventlet affected by HTTP request smuggling in unparsed trailers
IDs: CVE-2025-58068, GHSA-hw6f-rjfj-j7j7
Record: https://patchnext.com/advisories/cve-2025-58068 (revision 3, source checked 26 Oct 2026, 13:35 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: eventlet 0.40.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI eventlet: affected < 0.40.3; fixed in 0.40.3

## Suggested inspection (read-only)
- `python -m pip show eventlet`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on eventlet.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-hw6f-rjfj-j7j7 (OSV record GHSA-hw6f-rjfj-j7j7 lists affected ranges: PyPI eventlet >=0 <0.40.3 (fixed))
- Verified: https://github.com/advisories/GHSA-hw6f-rjfj-j7j7 (GitHub-reviewed advisory GHSA-hw6f-rjfj-j7j7 lists affected ranges: PyPI eventlet >=0 <0.40.3)

Commands are suggestions: review each one before running it.

Loading voting…