Skip to content

← Actionable
Medium, CVSS 4.2

Google Sign-In for Rails allowed redirect to protocol-relative URI

CVE-2025-58067GHSA-5jch-xhw4-r43v

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (google_sign_in 1.3.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
4.2 · CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:L/I:L/A:N
EPSS
  • CVE-2025-58067: 0.24% estimated exploitation activity in the next 30 days; percentile 14.57 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary It is possible to redirect a user to another origin if the "proceedto" value in the session store is set to a protocol-relative URL. Details The googlesignin gem persists an optional URL for redirection after authentication. If this URL is set to a protocol-relative URL, it improperly passes the "same origin" check, and it's possible for the user to be redirected to another origin after authentication, possibly resulting in exposure of authentication information if this attack is chained with other attacks. Normally the value of this URL is only written and read by the library or the calling application. However, it may be possible to set this session value from a malicious site with a form submission. Impact Any Rails applications using the googlesignin gem may be vulnerable, if this vector can be chained with another attack that is able to modify the OAuth2 request parameters. Workarounds No known workarounds. Credits This issue was responsibly reported by Hackerone user…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-5jch-xhw4-r43v

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-58067

Advisory: Google Sign-In for Rails allowed redirect to protocol-relative URI
IDs: CVE-2025-58067, GHSA-5jch-xhw4-r43v
Record: https://patchnext.com/advisories/cve-2025-58067 (revision 1, source checked 26 Oct 2026, 15:51 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.2)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: google_sign_in 1.3.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- RubyGems google_sign_in: affected < 1.3.1; fixed in 1.3.1

## Suggested inspection (read-only)
- RubyGems google_sign_in: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on google_sign_in.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-5jch-xhw4-r43v (GitHub-reviewed advisory GHSA-5jch-xhw4-r43v lists affected ranges: RubyGems google_sign_in >=0 <1.3.1)

Commands are suggestions: review each one before running it.

Loading voting…