Flask App Builder has an Authentication Bypass vulnerability when using non AUTH_DB methods
CVE-2025-58065GHSA-765j-9r45-w2q2
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (flask-appbuilder 4.8.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI flask-appbuilder
- Affected
- < 4.8.1
- Fixed in
- 4.8.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-765j-9r45-w2q2 lists affected ranges: PyPI flask-appbuilder >=0 <4.8.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-765j-9r45-w2q2 lists affected ranges: PyPI flask-appbuilder >=0 <4.8.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N
- EPSS
- CVE-2025-58065: 0.43% estimated exploitation activity in the next 30 days; percentile 37.61 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact When Flask-AppBuilder is configured to use OAuth, LDAP, or other non-database authentication methods, the password reset endpoint remains registered and accessible, despite not being displayed in the user interface. This allows an enabled user to reset their password and be able to create JWT tokens even after the user is disabled on the authentication provider. Patches Upgrade to Flask-AppBuilder version 4.8.1 or later Workarounds If immediate upgrade is not possible: - Manually disable password reset routes in the application configuration - Implement additional access controls at the web server or proxy level to block access to the reset my password URL. - Monitor for suspicious password reset attempts from disabled accounts
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-765j-9r45-w2q2
- Revision 1 · created ·
Published from osv record GHSA-765j-9r45-w2q2
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-58065 Advisory: Flask App Builder has an Authentication Bypass vulnerability when using non AUTH_DB methods IDs: CVE-2025-58065, GHSA-765j-9r45-w2q2 Record: https://patchnext.com/advisories/cve-2025-58065 (revision 2, source checked 26 Oct 2026, 13:35 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: flask-appbuilder 4.8.1. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI flask-appbuilder: affected < 4.8.1; fixed in 4.8.1 ## Suggested inspection (read-only) - `python -m pip show flask-appbuilder`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on flask-appbuilder. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-765j-9r45-w2q2 (OSV record GHSA-765j-9r45-w2q2 lists affected ranges: PyPI flask-appbuilder >=0 <4.8.1 (fixed)) - Verified: https://github.com/advisories/GHSA-765j-9r45-w2q2 (GitHub-reviewed advisory GHSA-765j-9r45-w2q2 lists affected ranges: PyPI flask-appbuilder >=0 <4.8.1) Commands are suggestions: review each one before running it.
Loading voting…