Skip to content

← Actionable
Critical, CVSS 9.1

Valtimo scripting engine can be used to gain access to sensitive data or resources

CVE-2025-58059GHSA-w48j-pp7j-fj55

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (com.ritense.valtimo:core 13.1.2.RELEASE, 12.16.0.RELEASE), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Maven com.ritense.valtimo:core

    Affected
    < 12.16.0.RELEASE>= 13.0.0.RELEASE, < 13.1.2.RELEASE
    Fixed in
    12.16.0.RELEASE, 13.1.2.RELEASE

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.1 · CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:H
EPSS
  • CVE-2025-58059: 0.40% estimated exploitation activity in the next 30 days; percentile 34.81 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Any admin that can create or modify and execute process-definitions could gain access to sensitive data or resources. This includes but is not limited to: - Running executables on the application host - Inspecting and extracting data from the host environment or application properties - Spring beans (application context, database pooling) Attack requirements The following conditions have to be met in order to perform this attack: - The user must be logged in - The user must have the admin role (ROLEADMIN), which is required to change process definitions - The user must have some knowledge about running scripts via a the Camunda/Operator engine Patches Version 12.16.0 and 13.1.2 have been patched. It is strongly advised to upgrade. Workarounds If no scripting is needed in any of the processes, it could be possible to disable it altogether via the ProcessEngineConfiguration: Warning: this workaround could lead to unexpected side-effects. Please test thoroughly. References -…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-w48j-pp7j-fj55

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-58059

Advisory: Valtimo scripting engine can be used to gain access to sensitive data or resources
IDs: CVE-2025-58059, GHSA-w48j-pp7j-fj55
Record: https://patchnext.com/advisories/cve-2025-58059 (revision 1, source checked 26 Oct 2026, 16:39 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: com.ritense.valtimo:core 13.1.2.RELEASE, 12.16.0.RELEASE. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven com.ritense.valtimo:core: affected < 12.16.0.RELEASE; >= 13.0.0.RELEASE, < 13.1.2.RELEASE; fixed in 12.16.0.RELEASE, 13.1.2.RELEASE

## Suggested inspection (read-only)
- Maven com.ritense.valtimo:core: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on com.ritense.valtimo:core.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-w48j-pp7j-fj55 (GitHub-reviewed advisory GHSA-w48j-pp7j-fj55 lists affected ranges: Maven com.ritense.valtimo:core >=0 =13.0.0.RELEASE <13.1.2.RELEASE)

Commands are suggestions: review each one before running it.

Loading voting…