Skip to content

← Actionable
Medium, CVSS 5.3

github.com/ulikunitz/xz leaks memory when decoding a corrupted multiple LZMA archives

CVE-2025-58058GHSA-jc7w-c686-c4v9

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/ulikunitz/xz 0.5.15), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
EPSS
  • CVE-2025-58058: 0.43% estimated exploitation activity in the next 30 days; percentile 37.61 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary It is possible to put data in front of an LZMA-encoded byte stream without detecting the situation while reading the header. This can lead to increased memory consumption because the current implementation allocates the full decoding buffer directly after reading the header. The LZMA header doesn't include a magic number or has a checksum to detect such an issue according to the specification. Note that the code recognizes the issue later while reading the stream, but at this time the memory allocation has already been done. Mitigations The release v0.5.15 includes following mitigations: - The ReaderConfig DictCap field is now interpreted as a limit for the dictionary size. - The default is 2 Gigabytes - 1 byte (2^31-1 bytes). - Users can check with the [Reader.Header] method what the actual values are in their LZMA files and set a smaller limit using ReaderConfig. - The dictionary size will not exceed the larger of the file size and the minimum dictionary size. This is…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-jc7w-c686-c4v9

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-58058

Advisory: github.com/ulikunitz/xz leaks memory when decoding a corrupted multiple LZMA archives
IDs: CVE-2025-58058, GHSA-jc7w-c686-c4v9
Record: https://patchnext.com/advisories/cve-2025-58058 (revision 1, source checked 26 Oct 2026, 15:10 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/ulikunitz/xz 0.5.15. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/ulikunitz/xz: affected <= 0.5.13; fixed in 0.5.15

## Suggested inspection (read-only)
- Go github.com/ulikunitz/xz: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/ulikunitz/xz.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-jc7w-c686-c4v9 (GitHub-reviewed advisory GHSA-jc7w-c686-c4v9 lists affected ranges: Go github.com/ulikunitz/xz >=0 <=0.5.13)

Commands are suggestions: review each one before running it.

Loading voting…