Netty's decoders vulnerable to DoS via zip bomb style attack
CVE-2025-58057GHSA-3p8m-j85q-pgmj
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (io.netty:netty-codec-compression 4.2.5.Final; io.netty:netty-codec 4.1.125.Final), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven io.netty:netty-codec-compression
- Affected
- >= 4.2.0.Alpha1, < 4.2.5.Final
- Fixed in
- 4.2.5.Final
Maven io.netty:netty-codec
- Affected
- < 4.1.125.Final
- Fixed in
- 4.1.125.Final
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-3p8m-j85q-pgmj lists affected ranges: Maven io.netty:netty-codec-compression >=4.2.0.Alpha1 =0 <4.1.125.Final
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 6.9 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2025-58057: 0.63% estimated exploitation activity in the next 30 days; percentile 50.28 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary With specially crafted input, BrotliDecoder and some other decompressing decoders will allocate a large number of reachable byte buffers, which can lead to denial of service. Details BrotliDecoder.decompress has no limit in how often it calls pull, decompressing data 64K bytes at a time. The buffers are saved in the output list, and remain reachable until OOM is hit. This is basically a zip bomb. Tested on 4.1.118, but there were no changes to the decoder since. PoC Run this test case with -Xmx1G: Error: Impact DoS for anyone using BrotliDecoder on untrusted input.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-3p8m-j85q-pgmj
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-58057 Advisory: Netty's decoders vulnerable to DoS via zip bomb style attack IDs: CVE-2025-58057, GHSA-3p8m-j85q-pgmj Record: https://patchnext.com/advisories/cve-2025-58057 (revision 1, source checked 26 Oct 2026, 16:39 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: io.netty:netty-codec-compression 4.2.5.Final; io.netty:netty-codec 4.1.125.Final. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven io.netty:netty-codec-compression: affected >= 4.2.0.Alpha1, < 4.2.5.Final; fixed in 4.2.5.Final - Maven io.netty:netty-codec: affected < 4.1.125.Final; fixed in 4.1.125.Final ## Suggested inspection (read-only) - Maven io.netty:netty-codec-compression: check the installed version with your package manager. - Maven io.netty:netty-codec: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on io.netty:netty-codec-compression, io.netty:netty-codec. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-3p8m-j85q-pgmj (GitHub-reviewed advisory GHSA-3p8m-j85q-pgmj lists affected ranges: Maven io.netty:netty-codec-compression >=4.2.0.Alpha1 =0 <4.1.125.Final) Commands are suggestions: review each one before running it.
Loading voting…