Volto affected by possible DoS by invoking specific URL by anonymous user
CVE-2025-58047GHSA-xjhf-7833-3pm5
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@plone/volto 19.0.0-alpha.4, 18.24.0, 17.22.1, 16.34.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm @plone/volto
- Affected
- < 16.34.0>= 17.0.0, < 17.22.1>= 18.0.0, < 18.24.0>= 19.0.0-alpha.1, < 19.0.0-alpha.4
- Fixed in
- 18.24.0, 16.34.0, 17.22.1, 19.0.0-alpha.4
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-xjhf-7833-3pm5 lists affected ranges: npm @plone/volto >=0 =17.0.0 =18.0.0 =19.0.0-alpha.1 <19.0.0-alpha.4 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-xjhf-7833-3pm5 lists affected ranges: npm @plone/volto >=0 =17.0.0 =18.0.0 =19.0.0-alpha.1 <19.0.0-alpha.4
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2025-58047: 0.67% estimated exploitation activity in the next 30 days; percentile 51.89 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact When visiting a specific URL, an anonymous user could cause the NodeJS server part of Volto to quit with an error. Patches The problem has been patched and the patch has been backported to Volto major versions down until 16. It is advised to upgrade to the latest patch release of your respective current major version: - Volto 16: 16.34.0 - Volto 17: 17.22.1 - Volto 18: 18.24.0 - Volto 19: 19.0.0-alpha4 Workarounds Make sure your setup automatically restarts processes that quit with an error. This won't prevent a crash, but it minimises downtime. Report The problem was discovered by FHNW, a client of Plone provider kitconcept, who shared it with the Plone Zope Security Team (security@plone.org).
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-xjhf-7833-3pm5
- Revision 1 · created ·
Published from osv record GHSA-xjhf-7833-3pm5
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-58047 Advisory: Volto affected by possible DoS by invoking specific URL by anonymous user IDs: CVE-2025-58047, GHSA-xjhf-7833-3pm5 Record: https://patchnext.com/advisories/cve-2025-58047 (revision 2, source checked 26 Oct 2026, 12:38 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @plone/volto 19.0.0-alpha.4, 18.24.0, 17.22.1, 16.34.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @plone/volto: affected < 16.34.0; >= 17.0.0, < 17.22.1; >= 18.0.0, < 18.24.0; >= 19.0.0-alpha.1, < 19.0.0-alpha.4; fixed in 18.24.0, 16.34.0, 17.22.1, 19.0.0-alpha.4 ## Suggested inspection (read-only) - `npm ls @plone/volto --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @plone/volto. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-xjhf-7833-3pm5 (OSV record GHSA-xjhf-7833-3pm5 lists affected ranges: npm @plone/volto >=0 =17.0.0 =18.0.0 =19.0.0-alpha.1 <19.0.0-alpha.4 (fixed)) - Verified: https://github.com/advisories/GHSA-xjhf-7833-3pm5 (GitHub-reviewed advisory GHSA-xjhf-7833-3pm5 lists affected ranges: npm @plone/volto >=0 =17.0.0 =18.0.0 =19.0.0-alpha.1 <19.0.0-alpha.4) Commands are suggestions: review each one before running it.
Loading voting…