Skip to content

← Actionable
Medium, CVSS 6.5amended

Next.js Improper Middleware Redirect Handling Leads to SSRF

CVE-2025-57822GHSA-4342-x723-ch2f

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (next 15.4.7, 14.2.32), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm next

    Affected
    >= 15.0.0-canary.0, < 15.4.7>= 0.9.9, < 14.2.32
    Fixed in
    14.2.32, 15.4.7

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.5 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:L/A:N
EPSS
  • CVE-2025-57822: 2.58% estimated exploitation activity in the next 30 days; percentile 85.26 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

A vulnerability in Next.js Middleware has been fixed in v14.2.32 and v15.4.7. The issue occurred when request headers were directly passed into NextResponse.next(). In self-hosted applications, this could allow Server-Side Request Forgery (SSRF) if certain sensitive headers from the incoming request were reflected back into the response. All users implementing custom middleware logic in self-hosted environments are strongly encouraged to upgrade and verify correct usage of the next() function. More details at Vercel Changelog

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-4342-x723-ch2f

  2. Revision 1 · created ·

    Published from osv record GHSA-4342-x723-ch2f

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-57822

Advisory: Next.js Improper Middleware Redirect Handling Leads to SSRF
IDs: CVE-2025-57822, GHSA-4342-x723-ch2f
Record: https://patchnext.com/advisories/cve-2025-57822 (revision 2, source checked 26 Oct 2026, 12:37 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: next 15.4.7, 14.2.32. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm next: affected >= 15.0.0-canary.0, < 15.4.7; >= 0.9.9, < 14.2.32; fixed in 14.2.32, 15.4.7

## Suggested inspection (read-only)
- `npm ls next --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on next.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-4342-x723-ch2f (OSV record GHSA-4342-x723-ch2f lists affected ranges: npm next >=0.9.9 =15.0.0-canary.0 <15.4.7 (fixed))
- Verified: https://github.com/advisories/GHSA-4342-x723-ch2f (GitHub-reviewed advisory GHSA-4342-x723-ch2f lists affected ranges: npm next >=15.0.0-canary.0 =0.9.9 <14.2.32)

Commands are suggestions: review each one before running it.

Loading voting…