Fides Webserver API is Vulnerable to OAuth Client Privilege Escalation
CVE-2025-57817GHSA-hjfh-p8f5-24wr
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (ethyca-fides 2.69.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI ethyca-fides
- Affected
- < 2.69.1
- Fixed in
- 2.69.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-hjfh-p8f5-24wr lists affected ranges: PyPI ethyca-fides >=0 <2.69.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-hjfh-p8f5-24wr lists affected ranges: PyPI ethyca-fides >=0 <2.69.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.6 · CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:H/VA:L/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2025-57817: 0.42% estimated exploitation activity in the next 30 days; percentile 36.41 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary The OAuth client creation and update endpoints of the Fides Webserver API do not properly authorize scope assignment. This allows highly privileged users with client:create or client:update permissions to escalate their privileges to owner-level. Details When creating or updating OAuth clients, the API validates only that requested scopes exist in the system registry. It does not verify that the requester already possesses the scopes they are assigning, allowing these users to assign arbitrary scopes to OAuth clients. Impact This allows contributor-level users to escalate to owner-equivalent privileges, gaining access to user management, system configuration, and permission assignment capabilities they should not possess. Patches The vulnerability has been patched in Fides version 2.69.1. Users are advised to upgrade to this version or later to secure their systems against this threat. Workarounds There are no workarounds. Risk Level This vulnerability has been assigned a…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-hjfh-p8f5-24wr
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-hjfh-p8f5-24wr
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-57817 Advisory: Fides Webserver API is Vulnerable to OAuth Client Privilege Escalation IDs: CVE-2025-57817, GHSA-hjfh-p8f5-24wr Record: https://patchnext.com/advisories/cve-2025-57817 (revision 3, source checked 26 Oct 2026, 13:35 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.6) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: ethyca-fides 2.69.1. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI ethyca-fides: affected < 2.69.1; fixed in 2.69.1 ## Suggested inspection (read-only) - `python -m pip show ethyca-fides`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on ethyca-fides. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-hjfh-p8f5-24wr (OSV record GHSA-hjfh-p8f5-24wr lists affected ranges: PyPI ethyca-fides >=0 <2.69.1 (fixed)) - Verified: https://github.com/advisories/GHSA-hjfh-p8f5-24wr (GitHub-reviewed advisory GHSA-hjfh-p8f5-24wr lists affected ranges: PyPI ethyca-fides >=0 <2.69.1) Commands are suggestions: review each one before running it.
Loading voting…