Skip to content

← Actionable
Low, CVSS 2.3amended

Fides has a Lack of Brute-Force Protections on Authentication Endpoints

CVE-2025-57815GHSA-7q62-r88r-j5gw

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (ethyca-fides 2.69.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
2.3 · CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2025-57815: 0.29% estimated exploitation activity in the next 30 days; percentile 22.19 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The Fides Admin UI login endpoint relies on a general IP-based rate limit for all API traffic and lacks specific anti-automation controls designed to protect against brute-force attacks. This could allow attackers to conduct credential testing attacks, such as credential stuffing or password spraying, which poses a risk to accounts with weak or previously compromised passwords. Details Fides uses a configurable, system-wide rate limit to control traffic from any single IP address. Because this single limit must be set high enough to accommodate endpoints that receive a large volume of legitimate traffic, it offers only weak protection for the login endpoint. The system is not equipped with more advanced protections tailored specifically for authentication Impact Although password complexity requirements and the global rate limit make a traditional brute-force attack against a single account difficult, the lack of authentication-specific protections exposes Fides to more…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-7q62-r88r-j5gw

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-7q62-r88r-j5gw

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-57815

Advisory: Fides has a Lack of Brute-Force Protections on Authentication Endpoints
IDs: CVE-2025-57815, GHSA-7q62-r88r-j5gw
Record: https://patchnext.com/advisories/cve-2025-57815 (revision 3, source checked 26 Oct 2026, 13:35 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 2.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: ethyca-fides 2.69.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI ethyca-fides: affected < 2.69.1; fixed in 2.69.1

## Suggested inspection (read-only)
- `python -m pip show ethyca-fides`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on ethyca-fides.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-7q62-r88r-j5gw (OSV record GHSA-7q62-r88r-j5gw lists affected ranges: PyPI ethyca-fides >=0 <2.69.1 (fixed))
- Verified: https://github.com/advisories/GHSA-7q62-r88r-j5gw (GitHub-reviewed advisory GHSA-7q62-r88r-j5gw lists affected ranges: PyPI ethyca-fides >=0 <2.69.1)

Commands are suggestions: review each one before running it.

Loading voting…