traQ Allows Insertion of Sensitive Information into Log File
CVE-2025-57813GHSA-27r7-3m9x-r533
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/traPtitech/traQ 3.25.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- < 3.25.0
- Fixed in
- 3.25.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-27r7-3m9x-r533 lists affected ranges: Go github.com/traPtitech/traQ >=0 <3.25.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.9 · CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:H/I:H/A:N
- EPSS
- CVE-2025-57813: 0.43% estimated exploitation activity in the next 30 days; percentile 37.64 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact A vulnerability exists where sensitive information, such as OAuth tokens, is recorded in log files when an error occurs during the execution of an SQL query. An attacker could intentionally trigger an SQL error by methods such as placing a high load on the database. This could allow an attacker who has the authority to view the log files to illicitly acquire the recorded sensitive information. Patch This vulnerability was temporarily fixed by #2787 and will be completely resolved by #2788. This issue may have caused OAuth tokens to be leaked to users who can view logs on traQ instances using versions prior to v3.25.0. While it is possible that OAuth tokens for both human users and Bots were leaked, revoking Bot access tokens is not recommended as it may cause errors. This issue will be resolved in a future update. Currently, the recommended mitigation is to invalidate the OAuth tokens of human users only. To apply this measure, please execute the following SQL statement…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-27r7-3m9x-r533
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-57813 Advisory: traQ Allows Insertion of Sensitive Information into Log File IDs: CVE-2025-57813, GHSA-27r7-3m9x-r533 Record: https://patchnext.com/advisories/cve-2025-57813 (revision 1, source checked 26 Oct 2026, 15:10 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/traPtitech/traQ 3.25.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/traPtitech/traQ: affected < 3.25.0; fixed in 3.25.0 ## Suggested inspection (read-only) - Go github.com/traPtitech/traQ: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/traPtitech/traQ. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-27r7-3m9x-r533 (GitHub-reviewed advisory GHSA-27r7-3m9x-r533 lists affected ranges: Go github.com/traPtitech/traQ >=0 <3.25.0) Commands are suggestions: review each one before running it.
Loading voting…